Unable to add an existing local vault on Android


Thanks for an excellent app which until recently has worked flawlessly.

I now am having a problem adding a existing local vault. I navigate through:

  • Click here to create an new vault
  • Add existing vault
  • Local storage
  • Click on the location
  • Click on masterkey.cryptomator

and then I receive the following very strange message:

**Vault is root folder of the cloud connection**

Create an new cloud connection where you
select at least the parent folder of this vault
folder as the root directory to add this vault.


I am confused to say the least as this is all completely local. Any help would be much appreciated.

Thank you


Hey and welcome to the Cryptomator Community :slightly_smiling_face:,

The following topic should help you:

Thank you for such a quick response.

I originally had the vault stored immediately under “internal memory” which I couldn’t select, so I moved the vault one directory level lower, followed your post, and it now works.

Thank you!



I’m going to answer here since I don’t think I should be answering on the FAQ topic (please move this message otherwise).
I had the same problem with my vaults. Basically I have the masterkey in /syncthing/KP/XXX/YYY. I started by adding YYY, but got the same error as above. No big deal, I figured I should add the XXX level. Except when I do it, I get a generic “An error occurred” error message (app was obfuscated during the screenshot but the error message wasn’t):

And nothing is shown in the navigation menu.

By mistake I found a workaround which was to add BOTH XXX and YYY (in no particular order, I tested both), and could use the XXX one to add the vault (strangely enough, XXX in the navigator was shown as YYY and YYY as XXX so I actually used YYY).

1 Like

Hey and welcome to the Cryptomator Community :slightly_smiling_face:,

Is this a reproducible behavior on your device?
What device an OS do you use?


Yes I could reproduce it on my device (actually did when I tried inverting XXX and YYY to see if it worked as well).
Now I realized something new, when starting the app again and trying to open said vault I get another error message “Vault YYY not found” (and a window asking me if I want to remove it). I can however remove it, and add it again afterwards.
I’m on a Pixel 6 with Android 12.

Stock Android?

Can you please enable debug mode, reproduce the problem and send us the log file? How do I enable debug mode on Android?

I seem to have run into this issue as well.

First I picked the folder the vault was in as my local cloud storage location and then tried to add an existing vault, but received the Vault is root folder of the cloud connection error.

So I removed the storage location and re-created it in the parent folder.

Then when trying to add the existing vault to that storage location, I receive the An error occurred error. I’ll also note that ANY command after this, such as creating a new folder in that location, fails exactly the same way.

If I add both storage locations (the parent folder AND the vault folder) I do not get around this like Mereck13579 did, although the symptoms he described appear to line up with what I saw otherwise.

Every time I add a storage location I get prompted by the OS to allow Cryptomater to access that folder.

Perhaps this is an access/permission problem in the latest android?

Stock Android, Pixel 6.

@xygnal can you please too enable debug mode, reproduce the problem and send us the log file? How do I enable debug mode on Android?

5 posts were split to a new topic: Unable to add an existing local vault on Android using EMUI (Huawei)