Windows 10 - No files showing when vault unlocked

Windows 10 N 1909
Crytomator 1.4.11 / 1.4.15

When I unlock my vault, the mounted drive shows no files. The corresponding folder of encrypted files (with ‘d’ and ‘m’ sub directories) shows thousands of files and is 13 GB in size. The files are all fully downloade from the cloud. Notably, there are two backup keys. I haven’t attempted to open this vault in about 6 months.

I’ve seen other posts on/ near to this subject but haven’t fould a resolution that works for me (sorry for not linking them all, limit on the # of links allowed):

  1. Cryptomator not showing some of my folders in the vault
  2. Missing files
  3. Cryptomator opens empty folder in Dropbox

As per (3), I’ve tried installing an older Cryptomator installer with an older vesion of Dokany:

We discussed the issue on GitHub: And came to the conclusion that the new Dokany version isn’t as backwards-compatible as we’ve thought. Here is the new installer with an older Dokany version: […] Does that work for you?

Also per (3), I tried a powershell script to test for/ correct missing 0 prefixes in file-names:

Get-Childitem -File -Depth 3 -Recurse | Where-Object{ $.Length -eq 36 -and $.Name -notlike “0*”} | Rename-Item -NewName {“0”+$_.Name}

Neither of these solutions had an effect. Any advice on the subject would be much appreciated.


Using Cryptomator 1.4.15, can you please:

  1. Unlock the vault
  2. Open settings and activate debug logging
  3. Press F5 in the empty drive
  4. Deactivate debug logging

Then send us the log file. Redact any paths you don’t want to show up in the log file and feel free to use the PN function for sending the log.

Thank you for this.

Uninstalled 1.4.11 and Dokany. Installed 1.4.15.

On attempt to unlock the vault now gives the message “Unlock failed. See log file for details.” The log includes “WARN - Error while mounting” and other errors. This is new behaviour. Previously, the drive moutned but with zero files showing both with 1.4.11 and 1.4.15.

I will send over the logfile in a moment.

Thanks for your help with this.

The exception from the log is:

ERROR o.c.ui.controllers.UnlockController - Unlock failed for technical reasons.
org.cryptomator.ui.model.Volume$VolumeException: Unable to mount Filesystem
	at org.cryptomator.ui.model.DokanyVolume.mount(
	at org.cryptomator.ui.model.Vault.unlock(
	at org.cryptomator.ui.controllers.UnlockController.lambda$didClickUnlockButton$0(
	at org.cryptomator.ui.util.Tasks.lambda$create$0(
	at org.cryptomator.ui.util.Tasks$
	at javafx.concurrent.Task$
	at java.base/
	at java.base/java.util.concurrent.Executors$
	at java.base/
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
	at java.base/java.util.concurrent.ThreadPoolExecutor$
	at java.base/
Caused by: org.cryptomator.frontend.dokany.MountFailedException: java.lang.IllegalStateException: Mount failed: Cannot install driver.
	at org.cryptomator.frontend.dokany.MountFactory.mount(
	at org.cryptomator.ui.model.DokanyVolume.mount(
	... 11 common frames omitted
Caused by: java.lang.IllegalStateException: Mount failed: Cannot install driver.
	... 5 common frames omitted

The same error has been reported before, in this thread as well as on GitHub.

Can you follow @infeo’s instructions given on GitHub to make sure, your Dokany installation is in order?

Thank you – the “Unlock failed. See log file for details” error is now resolved, so back to the original situation where the vault unlocks with no files showing.

I will send over the logfile in a moment.

Thanks for your help with this.

For the record, how did you solve it? Was it the Dokany update?

I think so, yes. I uninstalled then attempted to install the most recent version without restarting. The installer failed and indicated that removal of an earlier version was pending a restart. I restarted and installed the most recent version, which then allowed me to unlock the vault (albeit with no files.)