Can't open Microsoft Office Word documents in vault

Hi.

I have tried to create a vault in my OneDrive folder and it seems to mostly work. I created a new vault in the OneDrive folder and moved the files I want encrypted to the vault. However, I can’t seem to open all Word documents in the vault on my Windows 10 laptop, upon opening the vault via the Cryptomator program. The Word window opens with a dialog box saying “The file (then a sequence of numbers and letters) is not available”. Other file types such as Excel files appear to open fine. Any help would be appreciated.

Another thing, am I right in saying that any files in the vault will sync to the cloud service (in my case OneDrive) as do all unencrypted files stored in the OneDrive folder on my laptop? How would I access the files in my vault online?

Thanks, Matthew.

Maybe this issue is related to

If you want to access encrypted files online directly without cryptomators WebDAV drive, you canuse cyberduck.

An other suggestion for your issue is this:

Michael,

Thanks for your suggestions. It doesn’t appear to be an issue with special characters as a file with no special characters in the name doesn’t open. I checked my hosts file and the recommended line is already present.

I have looked in Microsoft Office Upload Center and there are no pending uploads and no recently uploaded files. I have attached a

screenshot showing the cached files. Uploads don’t appear to be paused.

Kind Regards, Matthew.

Another issue, if I may keep my posts together rather than open another thread.

I have tried to set up Cryptomator on Android and can open my vault but the app says “Empty folder”. Is this because the files haven’t synced from my laptop to OneDrive yet?

A question: do the files in a cloud vault sync to the same place as non vault files? I.e. I have some unencrypted files stored in my OneDrive account (which seem to be ok) plus some stored in a vault (most of which seem to be ok). Are they all stored in the same OneDrive account?

Thanks, Matthew.

Yes that can be a reason. Because Android app does not connect to your laptop (that would not make any sense).

Im not sure if I understand this question correctly, but of course “yes”. Assuming you use the OneDrive Sync Tool to sync your file local vs OneDrive, always the account configured in that tool is used (for encrypted vault files as well as for your other not encrypted files you want to sync online).
As far as I know it is possible to configure more than one account in OneDrive Sync Tool. But each account has its own local sync folder.

That’s a nice idea, but it is more advantageous to open a new thread for a new discussion/issue/theme. Then other readers can decide based on your headline, if the post content is interesting for them as well.

Regarding you initial problem:
Your screenshot shows various word documents which are in the upload-centers cache. If I look in my upload center, the cache is empty.
Is one of these files one you want to open and cannot be found?
Actually I guess the cause of your problem is in the microsoft upload center, but I dont have an Idea what exactly causes this (as I do not experience this and cannot reproduce it).
Hopefully other users have some more ideas.

Thanks for the reply.

OK, I’ll start a new topic next time. As far as my initial problem, I can open my Vault on my laptop and see the Word Document I want to open. Opening it brings up the dialog box saying the file is not available. In the Upload Center window it seems to list the last files (not just Word Documents) I have opened, successfully or otherwise. I agree that it might be to do with the Upload Center. It would be good if others have ideas to try and help.

Thanks again, Matthew. Apologies for the layout of my post; I’m a novice regarding forum posts.

I still can’t open Word documents, with the same error message appearing. Does anyone have any suggestions as to the problem and any potential solutions? As far as my other problem, I can now view my files in my Cryptomator vault on my mobile devices; it appeared to be a case of waiting for the files to sync fully.

Thanks, Matthew.

Hi. I’m just giving an update on my situation and to see if there are any potential solutions.

My problem is that when I open a .docx file (don’t know about .doc) I get a dialog box saying “The file (then a string of capital letters and numbers) is not available”, along with a black exclamation mark in a yellow triangle. In the Microsoft Office Upload Center the file appears under All Cached Files. I can open and edit Word documents if I move them to another, unencrypted folder and then move them back to my vault, but that adds a couple of extra steps to the whole thing. Any suggestions to overcome this would be appreciated.

Thanks, Matthew.

P.s. I now know to update existing threads rather than start new ones about the same topic.

I’m would still suggest that this is the issue I mentioned as Jan 06.

But responded, that there are no cached files. Now you have cached files. Have you tried the solution above?

Hi Michael.

I have checked the Office Upload Center and it appears that uploads were not paused. I could open a Word document from my vault on both my Android smartphone and Android tablet. However, they are read only copies, I don’t know if this is expected. I saved a copy of a Word document to my local storage on my phone but couldn’t open it from my file manager app, saying the application is not available (Word is installed on my phone). I am trying to repair Office365 on my laptop now.

Thanks for your continuing help.

Also, the file appears to be decrypted (spiked green line in the Cryptomator window) but also has a flat red line at the same time. I can’t open a document located in the vault from within Word itself either. I don’t know what repairing Office 365 did but it hasn’t seemed to affect the issue.

Unfortunately: it is (with android)

Thanks Michael.

So I would have to save the read only copy to Cryptomator once I have finished with it? I still can’t solve the problem in Windows 10 unfortunately.

If it helps, I’ve checked Event Viewer and the error gives an ID of 300, please see attached screenshot.

Regarding office, this post is my last idea.
Please check if the host record is set correctly and if not set it manually: Cryptomator installer is unable to write to hosts file

Regarding Android app:
Unfortunately I’m not on Android. But there are lots of posts here that describe the behavior of Android when updating files, and how to deal with it. Just search for Android.

Thanks for the suggestion, but I appear to have found a workaround. I have used a program called VSubst to map a folder in my vault to a drive letter. From the resulting virtual drive I can open Word documents in Protected View in Windows 10 and can enable editing if need be. The files then sync as usual. I’ll see if this method continues to work.

As for the Android app, I’ll have a look at those posts.

Thanks for your help, Matthew.

This issue isn’t directly caused by Cryptomator however could be a sideeffect of workplace and also the workplace transfer Center not operating properly.

One workaround for this issue is to repeat the files in question to a different directory outside of the vault (e.g. the Desktop), work with the files from there and replica back to the vault after.

Worked for me thanks

© 2020 Skymatic GmbH • Privacy PolicyImpressum