OneDrive temp files appear and remain when working on MS Office documents

Whenever I work on MS Office documents within the Cryptomator storage (that is synchronized with OneDrive) temp files appear in the folder and remain there even after closing the corresponding MS Office file. In order to get rid of these temp files I have to delete them manually. This behavior started with version 1.4.11. If I roll the software back to 1.4.10 everything works as expected again. The attached screenshot should clarify what these temp files are that I’m talking about.

P.S. The system is Windows 10 Pro 64 bit and OneDrive file on demand is turned off.

Am I really the only one with this issue?

I would like to help and tried to reproduce this, but my Office 365 does not create these tmp files, but “~abcd.xlsx” as long as the excel document is open. And this file is deleted after closing the excel document.
Maybe someone else.

Same with me. Got lots of temp files, even with LibreOffice.

I think, if I’m remembering correctly, this behaviour did not show up some versions ago.

I’m using cryptomator 1.4.15 with OneDrive on Win10 64bit and Dokany integration.

At least I’m not the only one :wink:

The described behavior was introduced with 1.4.11. I recommend rolling back to 1.4.10 (which I did) as a workaround until a fix for this issue is released.

Same issue here with Google Drive.

Due to Dropbox’s stupid “3 device only for free” policy I recently switched to Google Drive.
There is the same issue while working with MS Office documents like Excel or Word.
After saving it remains a *.tmp file and the built-in office copy, starting with ~$ in the name in the folder. I assume the problem might be related to this “office shadow copy”, since I don’t have the problem with other filetypes.

I’m not sure about the Cryptomater version it started with, but I didn’t had that issue with Dropbox on Version 1.4.12+.
(different computers, all running Windows 10 1809 or 1903 x64. All with Dokany integration).

Any thaughts how to solve that problem?

Yes, it would be nice if the developer could comment on whether it’s planned to fix this issue. Also I’d be more than happy to provide anything that might help to fix the problem (e.g. logs…).

Apparently the problem is related to the Dokany library.
I have a client which uses WebDAV (by accident) and on that client it seems I don’t have the tmp files.
I’m gonna test out a bit more and post the results here.

However, it would be great if a dev will give some information to the problem.
I’m also happy to provide logs, if needed.

@oeci @oggy512 What office version are you using? (standalone or within the office 365 bundle, 2019/2016) And what is your installed Dokany version?

I tried to reproduce it with Microsoft Office 2016 and Google Drive, but were unable to do so. The temporary ~$ files were deleted and I only noticed their creation/deletion because Google Drive asked me if these files should have been really deleted. Maybe your Google Drive settings are causing this. But maybe i got the wrong office version.

You can provide log files the following way:

  1. Activate Debug logging
  2. Create a fresh/empty vault
  3. Restart Cryptomator
  4. Unlock this new vault (only this!)
  5. Reproduce this bug/“left-over” file
  6. Lock the vault and close the application
  7. Upload the log file with Firefox Send and send me a PM with the link

Thanks for your reply.
Strange things happened… I enabled debug mode and created a new vault. After restarting of Cryptomator I got two errors “No main class specified” and “Failed to launch JVM”, see screenshot attached (I can attach just 1 pic…). No way to start it.
I had to uninstall and, to be on the safe side, I uninstalled Dokany as well (was v
After a reboot I installed the current version of Cryptomator and tried to reproduce the problem with enabled deug mode and new vault, but the problem didn’t appear.
Now it is gone in my original vault as well…
I’m happy of course, but strange. Might be becuase of the older version of Dokany? Cryptomator was the latest one before also.

Yesterday I updated MS VC++ to the latest version, was 14.21.x and now 14.23.x!c1

1 Like

Thanks for looking into it. Having read oggy512’s post I decided to uninstall cryptomator plus dokany. I then downloaded the latest dokany version from github (version and reinstalled cryptomator as well as dokany. Now the issue seems to be gone. Before uninstalling everything I also had dokany version on my system.

I uninstalled Cryptomator and Dokany on the other clients as well and updated to the latest version -> problem seems to be gone. Installing Cryptomator setup alone did install Dokany v1.3.0.1000, so no need for a separate installation of Dokany here.
Apparently the installer of v1.4.15 does not (correct?) update Dokany and this might led to the problem. Perhaps that’s something for a “known problems table”?!

Also I noted that after installing v1.4.15, v1.4.13 was still in the programs & features list, so Cryptomator was listed twice.
I could uninstall both, so the uninstaller did something twice, but there were still a ton of files in the program folder, which I had to delete manually (to make sure to have a clean installation).
This problem is reported in another thread as well, but i just wanted to mention it here also.

I had the same problem with Office .tmp files some weeks ago with an old Dokany version and an older version of Cryptomator. I switched to WebDav until this problem was solved :slightly_smiling_face:

I noticed that too, tried to uninstall the older version 1.4.13 and this uninstalled both versions of Cryptomator :face_with_raised_eyebrow:

Sigh, I should have guessed that Dokany is the problem here… Even thou they claim to be downward compatible, it seems this was not the case with the last major update and we just discoverd it after we updated the library shipped with Cryptomator. (not to be confused with the shipped Dokany installer (; ) Another problem is that currently we cannot update the Dokany installation in place, see here.

Regarding the two entries of Cryptomator: If you want to keep your settings, do not uninstall the old one! (see [Win 10] One issue discovered with 1.4.15 [Updated]) There is also a workaround for removing the old version without deleting all your settings.

1 Like

Upgrading to the latest Dokany drivers solved my problems so far. Thx.

That’s what I’m using:
Win10 Pro 64
Cryptomator 1.4.15
Dokan Library
Onedrive [Office 365]

Until you guys have a solution for an inplace upgrade of Dokany while upgrading Cryptomator, there should be at least a hint for users, to manually update Donaky…

1 Like

Yes, maybe a hint in the installer telling users to manually download and update dokany in case they run into issues like the one described in this thread.