iOS app, ownCloud 10.3.1 - http method "OPTIONS" not allowed

I just setup my first test vault and purchased the iOS app. I plan to store the files in my ownCloud folder.

When I try to login on the iOS app using WebDAV, I get a red banner with “http method “OPTIONS” not allowed” in the iOS app. The server is ownCloud 10.3.1 (latest stable release).

Edit: Never mind, I just found this post and realized I have to enter the complete URL not just the domain.

ownCloud https://{host}/{path}/remote.php/webdav

Now I had “wrong username and/or password”. Disabling two-factor auth on the server allowed me to login. Any idea how I can keep two-factor auth enabled but still be able to access vaults with Cryptomator iOS?

The “correct” way would be to generated app-specific passwords. However, I don’t think ownCloud has this option.

See also:

I dont’t know about OwnCloud but Nextcloud (the two are very similar) does support generating a app specific password and using this password, you can connect to the cloud again, even when 2FA is enabled.

Using Nextcloud you find it under your User Settings --> Security --> at the very bottom " Devices & sessions", there you can define a name (to identify it again) and create a password. Using your user name and the app specific password, you can connect to the cloud.

Thanks a lot guys. I successfully setup an app specific password with ownCloud (its under Personal > Security > App passwords / tokens) and was able to enable 2-factor auth again. Let the testing continue!

© 2020 Skymatic GmbH • Privacy PolicyImpressum