Copy a Cryptomator folder from the cloud to local storage and then open it offline

Hey,

I know that the iOS App Doesn’t support offline files. BUT why can’t I just download my Cryptomator container from Google drive to my local internal iPhone storage and then open it with Cryptomator? When I do that I see the data and folders. But when I go then offline and want to open a file, it says it needs some internet connection and doesn’t open the file. But why? All the files are local. It’s the same when I copy it to an usb flash drive.
It seems that the iOS App thinks that the data is still in the cloud. but it’s not. You see it in the Cryptomator folder size. It’s the real data what is on my local storage.
Thanks for your hints.
Cheers Paul

When you say “download my Cryptomator container from Google Drive”, do you mean that you copied or moved the whole vault folder and all files to the iPhone and can access that folder in the Files app under “On My iPhone”? If so, did you try adding this local Vault in the Cryptomator app using Add Vault ("+" button on the app’s start screen) > Open Existing Vault > Other File Provider > Select Vault Folder > On My iPhone > navigate to the folder you downloaded your vault files to

This should allow you to open this downloaded copy of your vault that is stored in google drive, but changes wouldn’t sync with google drive (since it’s local files only you’re looking at). Please be aware of that and careful so that if you change a file, you don’t end up with 2 sets of files and different versions of the files in two places and for example lose track of where you made which change to a specific file (in google drive or locally).

The original vault you see in the app that you’ve set up using the google drive connection tries to connect to google drive when you try accessing it, hence the requirement that you’re online. This configuration doesn’t have any knowledge about the files you’ve downloaded to some folder on your iphone, so you have to add the local version as a second vault. These two stay separate and do not synchronize.

@countzero I downloaded the new iOs app yesterday (Oct 26, 2023). I copied the entire vault folder to my phone. When I access it using airplane mode, it says it needs an internet connection.
I don’t use an cloud services.

Is there a setting I need to adjust?

When does it say that and where - which app exactly? For the approach with files being only available offline on the iPhone without any sync, your vault files would need to be in On my iPhone, not any other. Check that in the “Files” app to be sure.

To make sure I’m not telling you something wrong, I just opened the current version of the Cryptomator iOS app (2.4.9 (1094)) and can add and unlock a vault stored in the On my iPhone location (i.e. locally) while in airplane mode. Also creating a new one and storing it locally, then unlocking/locking works as expected in airplane mode.

If you ensured the location and it still does that, check the gear icon in cryptomator > about cryptomator to be sure it’s the 2.x app and try to open the vault from within that app. If that works but you get the message trying to access the vault another way - old cryptomator app still installed as well?

On the other hand, while in airplane mode, trying to open an unlocked online vault (onedrive) just stays on “loading” for than I wanted to wait (minutes). Trying to unlock a locked vault just doesn’t work - it loops back to the unlock message.

Ok, so thanks for asking for clarification. I’ll clarify more.
I am able to open the vault in airplane mode. But you know how the “download” cloud is on the right of the file before you can open a file? When I try to download, it says I need an internet connection. Now that sounds weird, when it shouldn’t be downloading anything, since the entire vault should be on my phone.

I’m also using the iOs 2.4.9 (1094)

See my first reply in this thread, where that’s explained a bit. Offline here means strictly offline/local with no sync, with all vault files under Files > On my iPhone. Given that you write “download”, it’s not an offline vault. The cloud storage provider integrates with iOS via the app you’ve installed (e.g. google drive, onedrive,…) and this cloud storage provider app may require you to be online to access the files regardless of their sync status. That may prevent you from accessing the already downloaded files while in airplane mode. In other words - Cryptomator, or any other app for that matter, can’t access the files because the cloud storage provider’s app requires you to be online.

This message had 8 screenshots, but because I’m a new user, it didn’t allow me to post more than 1 screenshot, I chose the best one to point out that vault is local

Well, the whole reason I made my comments was because, again, my vaults are 100% under
Files->On my iPhone. They are not in any cloud or online service

I made a BRAND new vault on my mac to test it.
While testing it again, i found another bug. I’ll summarize both of them here.

Issue 1. (original issue)

  • Copied entire encrypted vault folder to the iPhone using airDrop, and placed it in my Files App.
    CryptoVaultTest. It’s the only vault on my phone. I chose “Other File Provider”

  • The icons now have a cloud. If I click on it, it will “download”. As you can see, I’m able to “download”, which doesn’t make sense, a this is a local folder.

  • I now put my phone in airplane mode, and if I try to download the second one, I get You’re offline.

Issue 2. New maybe semi-related bug. Could probably be solved with the previous bug. I started off in Airplane Mode. When I got to this screen, it just crashed:

  • I closed the app, reopened, it and I was able to through the above steps, but with the same issue as the original issue.
  • This also proves that in Issue 1, the files are local, or I would never been able to open it.
    Note: This happens every single time I start from scratch in airplane mode

Hey @imroue thanks for bringing this issue up again!
I quickly tried it out and was able to reproduce your issue. It seems that iOS itself shows this message and hinders you from accessing the files. This is probably because we tell the files app that the file has not been downloaded yet - that’s also the reason why you see the cloud icon next to each item. Which is more or less correct as we do not distinguish between local storage and for example iCloud or any other location which you can select via the „other file provider“ option.

We could try to detect this case so that we just mark all files as downloaded if your vault is stored locally at „On my iPhone“.

Thanks @phil1995, that makes sense. Is this something in the works or did we just discover it? Will it be fixed otherwise?

Similar problem for me :grimacing: