"We detect an outdated Dokany version on your system" error even after deinstallation


I’m using Crytomator on Linux as well as Windows without any issues for several months. Now the following issue happens on Windows 10: I saw that there was an upgrade for Cryptomator on Windows, since I used Linux only for several months.

So I downloaded version 1.5.7 x64 and tried to install. There appear a popup that an old Dokany version was installed and I have to remove it fist. But I misread the dialog and assumed that I have to uninstall Cryptomator, so I uninstalled Cryptomator and rebooted. After running the setup again, I still got the Dokany error (where I found out that I misread it)


When searching for Dokany in Apps & Features, there is no app installed.

I made an screenshot but are not allowed to attach it, since the forum policies forbid posting more than one image per post.

I searched on the C: drive but only found C:\Windows\System32\CatRoot{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\dokan1.cat, no folder in any program dir where an uninstaller could be.

It’s also noticeable that even after I uninstalled Cryptomator before, there is still the C:\Program Files\Cryptomator folder:

C:\Program Files\Cryptomator>dir
23.08.2020  20:34    <DIR>          .
23.08.2020  20:34    <DIR>          ..
23.08.2020  20:34    <DIR>          app
30.04.2020  17:14           146.384 applauncher.dll
30.04.2020  17:14           188.880 Cryptomator.exe
24.07.2019  14:14           109.952 dokan1.dll
30.04.2020  17:14           627.992 msvcp140.dll
29.03.2018  15:04           827.728 msvcr100.dll
23.08.2020  20:34    <DIR>          runtime
30.04.2020  17:14            85.784 vcruntime140.dll
30.04.2020  17:14            60.784 WinFunctions.dll
               7 Datei(en),      2.047.504 Bytes
               4 Verzeichnis(se), 76.263.931.904 Bytes frei

However, this installation seems broken. When running Cryptomator.exe, a bunch of error popups appears: “No Main class specified” and “Failed to launch JVM”

Afterwards nothing happens. For me it seems that the uninstallation wasn’t successfully and some parts where left, that let the installer detect Dokany even if it’s not there. I searched for the “We detect an outdated Dokany version on your system” string in the github repo, hoping to find out what is exactly checked to create those message, but without success.

I also tried renaming C:\Program Files\Cryptomator (because I also haven’t any Cryptomator entry in the Windows uninstall settings any more after running the uninstallation), still getting the same Dokany error popup.

How can I fix this to install Cryptomator again?

Some information about the environment:

  • The old version (which was installed and uninstalled by me before the upgrade) was
  • Windows 10 2004 Pro is installed, recently upgraded from 1903
  • Dualboot Ubuntu 20 LTS with Windows 10

Welcome to the Cryptomator Community :slight_smile:

Good approach, but unfortunately you looked at the wrong spot^^ The Cryptomator installer has its own repository, see https://github.com/cryptomator/cryptomator-win.

The installer checks if the file C:\Windows\System32\drivers\dokan1.sys exists and compare the installed dokan version with the bundled one. If it cannot find any installed dokan (event thou dokan1.sys exists), the installer just assumes the bundled Dokan is newer.

There are two reports on our issue tracker, that dokan1.sys was not removed after uninstall. If this is the case, in the thread Vault unlocks and assigns drive letter, but later the drive cannot be opened you can find a solution to remove it.

I would suggest a reinstall. If you want to keep your settings, rename the folder %appdata%/Cryptomator to something else, uninstall and afterwards rename it back.

1 Like

Thank you for your fast reply! The problem with the reinstall is, that I wasn’t able to do so because both Cryptomator and Dokany weren’t listed in the installed apps of Windows (neither in the new Win10 settings, nor in the old system control panel). Also C:\Program Files\Cryptomator doesn’t contain an uninstaller.

In the meantime, I started trying something else: C:\Program Files\Cryptomator (which was remaining after uninstalling) contains dokan1.dll. The properties contains the version, which was (x64) in my case. So I downloaded the x64 installer from the Dokan Github Repo and installed it, followed by a reboot and uninstalling it.

Here I remember that the uninstaller asked me to close the Windows explorer and runtime broker. I clicked ok to let them close those processes. But it was not successfull:


On the first previous run (which may caused this issue?) I just clicked ok here, because I thought it means just the file explorer windows by “Windows Explorer”, which I closed all. But it seems he really want to kill the entire explorer process, because I killed explorer.exe and the runtime broker (had multiple processes) in the taskmanager. Afterwards, the uninstallation ran without any process termination messages.

However, it still ask me for a reboot after the installation. I rebooted and now I could install the latest Cryptomator. I also verified that C:\Windows\System32\drivers\dokan1.sys was gone now, which was not the case before. This should be similar to removing it manually. Maybe even cleaner, because we run the uninstallation instead of manually removing, which seems a good idea for kernel drivers that were deeply integrated in the OS.

For me it looks like that Dokany isn’t completely uninstalled because the explorer (and maybe also the runtime broker processes) was still running. Maybe this information could help for the other issues where dokan1.sys was not removed properly?

1 Like

I still have no idea what to do.

I am updating from 1.5.4 to 1.5.10 and as it seems, my files are in the “Dokany” version, not WebDAV.

Is WebDAV better?
Can i change this?

Anyway, the installer refuses to do anything, i should “uninstall Dokany” first.
I have no idea where and how to do this.

I search all options and menus in both the Installer and the installed Cryptomator version, but see no such “Apps and Features” option at all.

I was short of uninstalling and reinstalling the App, but then found this topic, which seems to say this is not what i would need to do.

So, please - how and where to uninstall my old Dokany version?

And should i use that at all?

Somehow, it seems that WebDAV would be better.
Can and should this be changed?

Please note, that i also use iOS and iPadOS Apps to access my files in Cryptomator.

Many, many thanks for any hint!

in general: I would say “no”, and I guess the cryptomator developers agree. Thats why they made dokany the default virtual file system.
This might interest you:

Yes. Go To the settings of the cryptomator app (not the vaults configuration, the app configuration) by cliking the icon in the upper right corner. Select the 2nd tab from left and change the volume type.

Like you uninstall any other software on Windows. Go to System preferences -> Apps and features. Select dokany and click “uninstall”

You search at the wrong place. Its a windows function, not a cryptomator function.

you only need to uninstall/reinstall latest version of dokany by hand. Or you can uninstall dokany and cryptomator, and then install cryptomator again, which will also install dokany in a suitable version.

Although Im using WebDAV too, I would not say this. It depends. If you want to handle files larger than 4GB or vaults that are larger than you system partition free space (no matter where you vault is actually located), then you don’t have a choice anymore and have to use Dokany, because WebDAV cannot handle this. In a most general aspect I would say dokany is the way to go, and default option.

Many, many thanks, Michael!

It came never to my mind, that the installer could refer to the OS deinstallation, as this is called “install and deinstall programs”.
But searching that now again, i see the it shows a title “Apps & Features” which i never noticed before.

I even tried exactly that yesterday and it shows that i have no “Dokany” installed that could be removed.

But i copied and pasted the name “Dokany” and did not type it in.
And this gave an empty result.

After your posting, i now typed the name and my Windows shows that i this installed, which is only similar to the name:

“Dokan Library (x64)” from 23.05.2020

Is this what the installed was refering too?

Than at least i understand why i had problems - and others probably too.

I will not uninstall this until further notice from you that this is the right thing, as i just tried to do so and the OS replied that “Windows-Explorer” and “Runtime Broker” need to be stopped.

So i am not fully sure that this is really the right thing, as other components than Cryptomator seem to use it and also the name is not the same.

I beg yuu to explain … and if possible expand and fix the text from the installer, as this is confusing indeed.

Many, many thanks again!

To show a bit of my dedication, i just got a donation license for “tja.cryptomator@XXX” :slight_smile:

Yes. Please uninstall and install the latest version (DokanSetup_redist.exe)

Many, many thanks!

I am up and running again - had no need for the github link, as the installer did the required thing already!

Any recommendations for “high performance” usage?
I am planning to upload lots and lots of stuff to OneDrive in a Cryptomator vault.

Only saw some options for the number of threads to use for a tresor, but maybe there are recommendations for uploading MANY files and also LARGE files?

Just asking :slight_smile: