Version 1.12.0 on MacOS 12.7.3 does not start anymore

Until version 1.11.1 Cryptomator worked perfectly on my MacBookPro from 2016, running MacOS Monterey 12.7.3. Just recently I updated Cryptomator to version 1.12.0, and since then Cryptomator would not start anymore. I see the word “Cryptomator” in the title bar, but only for a second or so.

I used the Console app on MacOS to find any error messages, and the one which appeared to be most useful was the following:

2024-02-24 16:19:44.380255 +0100	syspolicyd	assessment denied for Cryptomator-1.12.0-x64.dmg bundle:UNBUNDLED Cryptomator-1.12.0-x64.dmg UNKNOWN 3 denied:no usable signature
SenderMachUUID: 6EBD779B-5452-3CEC-B195-C0EEFC698D55

Not sure if it is important: I have installed macFUSE version 4.6.0 (the latest version).

So, is there someone out there who has the same problem or - even better - has a solution to this problem?

For the time being I downgraded again to version 1.11.1 which still works.

Thanks for any info in advance, best regards, Martin

Welcome to the Cryptomator Community :slightly_smiling_face:

Your issue sounds a lot like Doesn't work anymore.

Cryptomator 1.12.0 requires macOS 11 or higher. Buuut since you seem to fullfill this requirement, i can’t say what causes this. According to other users which also had issue with syspolicyd, a complete removal and re-installation fixed the problem.

Hi @infeo, thanks for your reply and your suggestion for what might be the reason for this problem. Unfortunately, uninstalling (that is, deleting the folder from the Applications folder) did not help, even after restarting the Mac. I even removed the plist files which Cryptomator apparently created, but as I said: this did not help.

So, I am still stuck with version 1.11.1 to get access to my Cryptomator vaults.

Do you (or anyone else) have any other idea?

What you can do is start Cryptomator from the terminal and post the output of the terminal here. If the application starts and exits immediately, there should be some output of the cause.

What you can do is start Cryptomator from the terminal and post the output of the terminal here.

Oh, that was a good hint. I did this, and Cryptomator crashed indeed, and it created the following output on the terminal:

martin@mbp MacOS % ./Cryptomator

23:52:41.488 [main] INFO o.c.common.settings.SettingsProvider - Settings loaded from /Users/martin/Library/Application Support/Cryptomator/settings.json

23:52:41.575 [main] INFO org.cryptomator.common.Environment - user.home: /Users/martin

23:52:41.575 [main] INFO org.cryptomator.common.Environment - java.library.path: :/Applications/

23:52:41.575 [main] INFO org.cryptomator.common.Environment - user.language: en

23:52:41.575 [main] INFO org.cryptomator.common.Environment - user.region: null

23:52:41.575 [main] INFO org.cryptomator.common.Environment - logback.configurationFile: null

23:52:41.575 [main] INFO org.cryptomator.common.Environment - cryptomator.settingsPath: /Users/martin/Library/Application Support/Cryptomator/settings.json

23:52:41.575 [main] INFO org.cryptomator.common.Environment - cryptomator.ipcSocketPath: /Users/martin/Library/Application Support/Cryptomator/ipc.socket

23:52:41.575 [main] INFO org.cryptomator.common.Environment - cryptomator.integrationsWin.keychainPaths: null

23:52:41.576 [main] INFO org.cryptomator.common.Environment - cryptomator.p12Path: /Users/martin/Library/Application Support/Cryptomator/key.p12

23:52:41.576 [main] INFO org.cryptomator.common.Environment - cryptomator.logDir: /Users/martin/Library/Logs/Cryptomator

23:52:41.576 [main] INFO org.cryptomator.common.Environment - cryptomator.loopbackAlias: null

23:52:41.576 [main] INFO org.cryptomator.common.Environment - cryptomator.mountPointsDir: /Users/martin/Library/Application Support/Cryptomator/mnt

23:52:41.576 [main] INFO org.cryptomator.common.Environment - cryptomator.minPwLength: null

23:52:41.576 [main] INFO org.cryptomator.common.Environment - cryptomator.appVersion: 1.12.0

23:52:41.576 [main] INFO org.cryptomator.common.Environment - cryptomator.buildNumber: dmg-5144

23:52:41.576 [main] INFO org.cryptomator.common.Environment - cryptomator.pluginDir: /Users/martin/Library/Application Support/Cryptomator/Plugins

23:52:41.576 [main] INFO org.cryptomator.common.Environment - cryptomator.showTrayIcon: true

23:52:41.576 [main] INFO org.cryptomator.common.Environment - cryptomator.disableUpdateCheck: null

23:52:41.576 [main] INFO o.cryptomator.launcher.Cryptomator - Starting Cryptomator 1.12.0 on Mac OS X 12.7.3 (x86_64)

23:52:41.609 [main] INFO org.cryptomator.ipc.Server - Spawning IPC server listening on socket /Users/martin/Library/Application Support/Cryptomator/ipc.socket

23:52:42.005 [JavaFX Application Thread] INFO o.cryptomator.launcher.Cryptomator - JavaFX runtime started after 903ms


# A fatal error has been detected by the Java Runtime Environment:


# SIGILL (0x4) at pc=0x00007ff80a2a200a, pid=2397, tid=259


# JRE version: OpenJDK Runtime Environment Zulu21.32+17-CA (21.0.2+13) (build 21.0.2+13-LTS)

# Java VM: OpenJDK 64-Bit Server VM Zulu21.32+17-CA (21.0.2+13-LTS, mixed mode, tiered, compressed oops, compressed class ptrs, g1 gc, bsd-amd64)

# Problematic frame:

# C [CoreFoundation+0x1b900a] CFRelease.cold.1+0xe


# No core dump will be written. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again


# An error report file with more information is saved as:

# /Applications/

[2.710s][warning][os] Loading hsdis library failed


# If you would like to submit a bug report, please visit:


# The crash happened outside the Java Virtual Machine in native code.

# See problematic frame for where to report the bug.


zsh: abort ./Cryptomator

I wanted to upload the complete error log file “/Applications/” mentioned in the error output, but as new user I am apparently not yet allowed to do such uploads here.

FYI: I just tried the new version 1.12.3, but no luck again. When run via the Terminal the error message printed there is the same. Before I also uninstalled the openjdk I had installed via homebrew.

Just to add that I’m having the same problem. I have gone back to 1.11.1 which is fine.

1 Like

Thanks for adding your comment - now I do not feel so alone anymore :slight_smile:

Question: Do you have the exact same MacOS version than I do, or do you use a different one?

I’m using macOS 12.7.3 on a 2019 iMac. I hear that parts of Cryptomator are written in Java but it does not depend on it being installed separately. Java (Version 8 Update 401) is installed on my Mac but the chances of any conflict seem very remote. So far Cryptomator 1.11.1 is OK so I guess I’ll stick with it for now.

FYI: I just tried the Cryptomator version 1.12.3 again, this time on the just recently updated MacOS 12.7.5, but still no luck. I still only see “Cryptomator” in the title bar for about one second until it vanishes again. Luckily, going back to Cryptomator version 1.11.1 still works.

So, I am not sure now what to do. Has someone from the devs tried to investigate this problem a bit further?

@martin.leggewie You can send me the hs_err_pidXXXX.log via PM. Alternatively, send a mail to referencing this forum entry.

Additionally, can you do the following?

  1. Open /Applications/
  2. Add the below line to the file and save it.
  1. Quit Cryptomator and ensure it is not running (check the menu bar!)
  2. (Re-)start Cryptomator over the terminal and redirect output into a file:
/Applications/ 2>&1 > ~/Desktop/cryptomator_gui.log

The file cryptomator_gui.log is located on your Desktop. Also send this file.

Thanks for the reply! I have just sent the more detailed info (that is, the two log files) to you via PM.

Thanks for creating the logs. I had a look at them.

The reason for the app not starting lies within the font loading of the graphical framework (JavaFX) (specifically, a NULL pointer is released while searching for fonts). So if you altered the system default font, there might be a reason in the failure.

But wether this bug is specific to your setup or a bug in JavaFX i cannot say.

JavaFX recieved according to its release notes afterwards some updates regarding font loading. But it is yet not decided, if for the upcoming Cryptomator 1.13.0 release also JavaFX is updated. So for now i can only suggest to reset your fonts or wait until we update JavaFX.


Magic! Resetting the fonts to the factory default solved the problem. :smiley:

I have just installed cersion 1.12.3 again, and this time Cryptormater just started as usual, and I could unlock a vault. Not sure what to say … computers are really complicated at times.

Thanks a lot that you took the time and investigated the problem - maybe your solution will also help others. Regards, Martin

1 Like

Not sure if you receive a notification each time something happened in this topic, but better you receive the info twice than not at all: A dev has found a solution which worked at least on my Mac - see his entry from today which I marked as a solution. Regards, Martin