Vaults not locking

I’m using Linux Tumbleweed Gnome. Getting an error whenever I try to lock a vault. How to fix this?

Details here: Screenshot from 2024-03-22 16-48-59.png - Google Drive

There error is still there after a reboot.

I created a new vault and it had the same error. Should I uninstall and reinstall the app?

This is a feature that prevents loss of your data by stopping a vault from being locked if a program is accessing your decrypted files. For example, a document opened in Word.

To successfully lock a vault you will have to close those applications. Take a look at this thread for more info - Linux vault wont lock. Says another program is using it. Sometimes, apps don’t release a file even when their work is done. If you are sure that’s the case, you can use the Force lock option to lock the vault.

1 Like

Force Lock is greyed out so I can’t select it. Any way to fix that?

OK, thanks. Any easy way to find out which “open” file is causing the problem?

The problem is that the file may not actually be open and in memory anymore. It might be in an unnatural state and you won’t see it in a list of open files that are really running at the moment.

Sometimes a person will unlock their vault open a file in Microsoft Word and then reboot their computer. Sometimes not on purpose.

Make sure that all of your programs that you use with the Vault are closed.

Make a backup copy of any files that you recently modified. Copy them somewhere outside the vault.

Forcibly terminating the process for the software should lock the vault.

1 Like

I tried uninstalling and re-installing the Cryptomator flatpak. Still not working. It’s still not locking the vaults. I tried creating new vaults and same error.

Unless someone has a solution, I’ll give up on Cryptomator and try another encryption app.

Yes, It locked the vault, but locking the vaults that way is not a long term solution.

I tried that. I closed all running programs and still got the same error.

Looks like something got corrupted. I’m a Linux noob so I have no idea how to identify the source of the problem.

I tested Cryptomator (flatpak-version) on a up-to-date Fedora distribution and i could lock the vault without any issue.

My testing routine was:

  1. Open Cryptomator vault (without changing any vault config)
  2. Open file Welcome.rtf with LibreOffice
  3. Click “Lock vault” button → notified me about open file
  4. I closed LibreOffice
  5. Blick “Lock vault” button again
    → vault closed without any issue

You can open a terminal and execute the command below to find which app is still accessing it
lsof [path to the unlocked vault which you cannot lock] (ref)

You can find the path of the unlocked vault below the “Reveal Drive” button in Cryptomator.

1 Like

OK, that worked. The offending app was Nautilus preventing locking. Looks like this problem started after my upgrade to Gnome 46. So consider this a bug report that the Gnome 46 version of Nautilus is causing this problem with Cryptomator.

Does the dev read posts in this forum? I don’t know who the dev is.