Linux vault wont lock. Says another program is using it

Even after a reboot and forgetting the vault and readding it, it still says this and wont allow the vault to lock. It only does this for one vault. The rest are unaffected. How can i fix this? Thank you for any help.

Graceful lock failed.

Can you please open a terminal and execute
lsof [path to the unlocked vault which you cannot lock]

Then we know which process still accesses it.

Do you need a screen shot? I did the lsof command and it gave errors.

It says no such file or directory.

If i just use the lsof command by itself ,I see a huge list of everything running. Including cryptomator.

This vault that is doing this does the same thing on a windows machine.

So the command you executed is something like?

lsof /home/julian/Pictures

Hmm maybe the log file brings some light into this, do you find some WARNings or ERRORs inside?

Yes thats the command i did but, there are multiple words in the folder name. It gave an error for each word in the name like it didnt recognize the whole name. I did a killall -e cryptomator and it still does it. Not only will the vault not lock, cryptomator wont close. I did a healthcheck and everything was fine except shortened file names.

I wound up just doing a plain lsof . This worked however it listed every process.

You are sure that you didn’t execute the command in the encrypted folder like e.g.
lsof ~/pCloudDrive/all\ in\ single\ folder\ for\ sync\ 3-21-021/ (that would be the wrong one)? The easiest one would be to click on Reveal drive after unlocking the vault and starting in this directory a terminal, you then can also execute lsof .

Hmm yes, I see those c9s's inflated filename could not be decrypted. errors too but those shouldn’t affect the locking of a vault AFAIK :thinking:

No thats not what i did. I started command lsof from the folder after revealing the drive and it does the same thing. It lists every process from the computer. If i scroll down, i can see the cryptomator ones. Do i just kill these?

Because the vault thats doing that is also doing it on a windows machine ,but just that one vault, could it be the vault that is causing it?

Did you missed the dot at the end? It stands for current directory (lsof .)

That sounds a bit like it, but I can’t really imagine the cause behind it yet.

Yes I missed the dot. Thank you.

Could this be a bug that needs to be fixed? Is my vault corrupted? Would that show in the healthcheck? Or would the healthcheck only show if the files were corrupted?

I wanted to let you know i reuploaded the vault contents and made a new vault. It still wouldnt lock but this time all my vaults wouldnt lock. I decided to try webdav and open the webdav ports in the computer firewall. This wound up fixing it. Now the vaults lock on both linux and windows. Webdav fixed it. On linux fuse folder contents would disappear. Could a firewall cause this?

Merry Christmas! I hope you enjoy your holidays.

It could yes but currently I don’t think so especially what you write later on by fixing it.

Again, what did lsof . report, which process is still accessing this vault folder when you try to lock it?

Not the complete vault but some long file or folders where not listed in the explorer. Please make sure that the syncronisation of the folder is completely finished. Then you should be able to run a healthcheck which will also complain about those missing files.
if I am not mistaken, the healthcheck can recover the files, but not their names, but I would run the healthcheck in any case. Before executing the recovery, it is recommended to create a backup of the vault folder.

Happy new year :fireworks:

Lsof has three processes. One bash and two lsof. I think the bash one is the terminal. Happy New Year! :confetti_ball::tada: