.tmp Folder in Android

Hi… I’ve been using Cryptomator since 2017, best apps! Thanks for developing it.
Anyway, .tmp folders showed up in my Android phone, I tried to delete it but it keeps coming back. tmp folders show up only in my android phone but not in my desktop system. How to delete it? Any help is highly appreciated. Thanks

MSI temp folders are created by microsoft installers usually - e.g microsoft office makes them during patches/updates.

They are not produced by cryptomator. A program you a running is using the Cryptomator mounted drive as a temporary path.

It’s likely these are being created on the desktop , but you can not see them as they may be flagged as hidden or system folders.


Update: You can easily delete the .tmp folder by doing a simple procedure.

  1. Open the .tmp folder in your android. You will get this notification.

  1. In your desktop, locate that folder and delete (Make sure Cryptomator vault is closed).


1 Like

@boyett thanks for your feedback.
We enhanced the deletion process, that you can delete folders without a directory-file:

We will publish this with the next release!

1 Like

I am having this same issue now, MSI .tmp folders are being created and cannot be deleted. Show up in Android. Cannot follow the solution above because Cryptomator only says “An error occurred” and no additional information. I tried renaming the file but it created a second MSI folder that also cannot be deleted.

While deleting the folder this message is displayed or while renaming?

I can reproduce that when I rename a folder without an dir.c9r-file (like your .tmp folders), that it creates a new folder with the target name and shows An error occurred because it couldn’t move the dir-file. But I’m able to delete both folders without any problem.

Can you please enable debug mode, try to delete those folders again and send us the log file? How do I enable debug mode on Android?

There exists also a ticket on our bug tracker for this one: Android app shows "strange" files that do not exists in vault · Issue #1436 · cryptomator/cryptomator · GitHub

1 Like

Yes I have found that type of bug before but in each of those instances it give you text information and the name of the file that you can take action on. I get none of that, I only get “An error occurred”, can’t track down the culprit with that kind of info.

Thank you for the log file, we will look at it and try to find the cause why you can not delete those folders.

@Ztark Thanks for reporting this bug. We can reproduce it and will provide a fix in version 1.7.5 soon. Further information in "Unable to load contents of directory" dialog is not shown using Local storage if `dir.c9r` file is missing · Issue #437 · cryptomator/android · GitHub. With version 1.7.5 you will be able to delete these folders again.