Outdated component: Dokan File System Driver

Hallo, ich weiß, das Thema wurde schon häufiger behandelt und das hier soll der Lösungsweg sein. Abgesehen davon, dass ich mit ihm heillos überfordert bin, scheint mir das Problem in meinem Fall allerdings etwas anders zu liegen:

Während sich das Problem meinem bisheringe Verständnis nach üblicherweise so darstellt, dass nach der Deinstallation von Dokany die Datei C:\Windows\System32\drivers\dokan1.sys nicht entfernt wurde und es deswegen zu Problemen bei der Installation von Cryptomator kommt, ist es mein Problem, dass sie gar nicht da ist und Dokany deswegen offenbar nicht deinstalliert werden kann. Daher bleibe ich schon beim ersten Schritt des Lösungswegs (“Ensure that Dokany is uninstalled”) hängen.

Ich wäre für jede Hilfe dankbar!

Hi, I know the topic has been covered many times before and this is supposed to be the solution. Apart from the fact that I am hopelessly overwhelmed with the walkthrough, it seems to me that the problem in my case is somewhat different:

While I understand it the problem is usually that after uninstalling Dokany the file C:\Windows\System32\drivers\dokan1.sys is not removed and therefore there are problems installing Cryptomator. My problem on the other hand is that it is not there at all and therefore Dokany cannot be uninstalled. Therefore, I get stuck at the very first step of the walkthrough (“Ensure that Dokany is uninstalled”).

I would be grateful for any help!

Wilkommen zur Cryptomator Community :slightly_smiling_face:

Ich gehe mal davon aus, dass trotz der Nicht-Existenz von C:\Windows\System32\drivers\dokan1.sys Cryptomator behauptet, dass Dokany installiert ist, richtig?

Über welchen Version von Cryptomator sprechen wir hier? Seit 1.5.14 kann man auch veraltete Versionen von Dokany ignorieren. Das ist vielleicht nicht optimal, aber so wird kein Cryptomator-Update verhindert.

Vielen Dank für die schnelle Antwort!
Zur Nachfrage: Ja, das ist korrekt. Cryptomator behauptet, Dokany sei installiert, obwohl dokan1.sys nicht existiert.
Meine aktuelle Version ist leider 1.5.8.

Ach, sorry, ich meine das in allen Installern ab Version 1.5.14 der Versionsunterschied ignoriert werden kann. Sollte im Installationsprozess erklärt sein. Du musst auch nicht streng eine neue Version nach der anderen Installieren, sondern kannst über die aktuelle Installation einfach 1.5.16 drüberbügeln.

Wenn du gerne die aktuellste Dokany-Version installieren möchtest: Suche in deinem Windows- und in deinen Programmverzeichnissen mal nach den Dateien dokan1.dll und dokan1.sys und schreibe, wo diese gefunden wurden.

Eine weitere Möglichkeit ist, Dokany selbst zu installieren (vielleicht stimmt bei unserem Check etwas nicht). Der folgende Link führt zum Installer der aktuellsten Version 1.4.1.1000. Dokan_x64.msi herunterladen und ausführen:
https://github.com/dokan-dev/dokany/releases/download/v1.4.1.1000/

Die Datei dokan1.sys existiert bei mir offenbar überhaupt nicht. Die Datei dokan1.dll befindet sich an zwei Orten, in C:\Windows\System32 sowie in C:\Windows\SysWOW64.

Mein Fehlermeldung bei der Installation von Cryptomator 1.5.16 sieht so aus:

Dokany wird unter “Apps und features” aufgelistet. Die Deinstallation scheint aber irgendwie nicht zu funktionieren. Das ist so in etwa mein Problem.

Bei dem Versuch Dokany selbst zu installieren, gibt es dasselbe Problem:
Screenshot 2021-05-05 160710

Vorläufige Lösung gefunden: Mit RevoUninstaller habe ich alle Einträge in der Registry gelöscht. Danach konnte ich Dokany neu installieren und dann auch Cryptomator. Vielen Dank für die freuncliche Unterstützung!

Oh, na das ist schön :smiley:

© 2021 Skymatic GmbH • Privacy PolicyImpressum