Not possible to delete files inside vault drive - the come back


i have made a fault drive in my local Dropbox file share. The dropbox is synced with 2 other users (inside ~ 1 GB data). Monthly it has worked without problems. Now I suddenly have files that are corrupt or which can not be deleted. After deleting they comoe back.
Is there a tool with which one can repair the corrupt areas of the file system? Or is there a another solution ?


Do you really mean files or do you mean folders? Now that I think about it, this issue is probably affecting Dropbox as well (not just Google Drive):

We’ve wanted to fix that with the next patch 1.3.2. If you think you’re experiencing a different issue, please check the log file for errors.

yes, i mean single files not folders. Where is the LOG file stored? I have version 1.3.1.

The error with Google Drive is the same. I have the problem with files and not with folders.

You probably didn’t notice in my last post, but “log file” was a link. :grin: Here it is again: Where is the log file located?

Hm, that would be really weird if it’s the exact same issue because the GitHub issue I’ve linked was specific to folders. As @overheadhunter has mentioned there, the problem is that Cryptomator fails because the folder it tries to delete is not empty.

If you can find any errors inside the log file, please let us know.

I found this in the log file (cryptormator not started in the debug mode) after i had tried to delete the files. In a part of the log there is a “WARN”

23:03:54.865 [pool-4-thread-1] INFO o.e.j.server.handler.ContextHandler - Started o.e.j.s.ServletContextHandler@bcc433{/yh5TgREfQ2Uz/LMI_Verwaltung,null,AVAILABLE}
23:03:54.867 [pool-4-thread-1] INFO o.c.f.w.s.WebDavServletController - WebDavServlet started: /yh5TgREfQ2Uz/LMI_Verwaltung
23:03:54.973 [pool-4-thread-1] INFO o.c.f.w.s.WebDavServletController - Mounting using org.cryptomator.frontend.webdav.mount.WindowsMounter
23:04:01.060 [pool-5-thread-26] WARN o.c.cryptofs.CryptoDirectoryStream - Broken directory file C:\Daten\Dropbox\LMI Verwaltung\d\N3\BV23MNTU2GMY53UT3IH5A7ZM7LDMPI\0KYV7ELRHEO5I5QNQXWA2NQGMTSRND7UROGXKRP3BVY4IO===. Directory C:\Daten\Dropbox\LMI Verwaltung\d\RX\5GZ3Q6DAPYHX3R7ODGXUCVN3VC23N6 does not exist.
23:04:01.060 [pool-5-thread-26] WARN o.c.cryptofs.CryptoDirectoryStream - Broken directory file C:\Daten\Dropbox\LMI Verwaltung\d\N3\BV23MNTU2GMY53UT3IH5A7ZM7LDMPI\0QFG522P7E4JAFKWNAQKO6RUPXNN3WQ2VQVOUJ72RYBH62Q4K. Directory C:\Daten\Dropbox\LMI Verwaltung\d\DM\H72E6TSL2UCPQMYRUWUSQ5KTQ57LDY does not exist.
23:04:01.668 [pool-5-thread-39] WARN o.c.cryptofs.CryptoDirectoryStream - Broken directory file C:\Daten\Dropbox\LMI Verwaltung\d\JY\43TZ2MPSZKWRXDSDWQ7KGARNCKUB75\02DAAPVNQ2E5X4KS7UBNFID6RWUCXH2327XGA====. Directory C:\Daten\Dropbox\LMI Verwaltung\d\FW\OUAN24BQAJFU4GCRJEZSGIDK2OGR7N does not exist.
23:04:40.607 [JavaFX Application Thread] INFO o.e.j.server.handler.ContextHandler - Stopped o.e.j.s.ServletContextHandler@bcc433{/yh5TgREfQ2Uz/LMI_Verwaltung,null,UNAVAILABLE}
23:04:40.607 [JavaFX Application Thread] INFO o.c.f.w.s.WebDavServletController - WebDavServlet stopped: /yh5TgREfQ2Uz/LMI_Verwaltung
23:04:40.635 [JavaFX Application Thread] INFO o.c.k.WindowsProtectedKeychainAccess - Creating new keychain at path C:\Users\Boris\AppData\Roaming\Cryptomator\keychain.json
23:04:42.863 [JavaFX Application Thread] INFO o.c.launcher.MainApplication - JavaFX application stopped.
23:04:42.877 [Thread-1] INFO o.c.launcher.CleanShutdownPerformer - Goodbye.

Thank you for looking into the log file. From the warning, it looks like this issue:

The warning is still somehow directory-related but maybe it’s a side effect. This is also going to be fixed in the next patch 1.3.2. We’ll release it as soon as possible.

New error: many corrupt files.
I now have numerous PDF and .docx files which are defective and can no longer be opened.
But: In the same directory, there are files that are not corrupt !?
I think I now have to stop using Cryptormator. There is the risk of losing more files.
Is it known when the new version will fix the bug? When do you release the new version?

Again in the log:
d-18] WARN o.c.cryptofs.CryptoDirectoryStream - Broken directory file C:\Daten\Dropbox… g\d\DM\H72E6TSL2UCPQMYRUWUSQ5KTQ57LDY does not exist.

I have the same problem! Sometimes I cannot remove/delete files. This occours after removing a directory where some files are still left and cannot be removed.
So I stopped using Cryptomator, hopefully this things can be fixed somewhere in the future.

I have found out that the files where the Filename contains a " ; " which leads to these files become corrupt after a time of xx. I do not know how long (xx) it takes. First I could open the files without problems again and again. Suddenly, they were corrupt and could not be deleted. I am now also waiting for the new version without this bug.

Yup. I’m coming in to say the same thing here. I took another look at Cryptomator for keeping my files encrypted, I was considering how I can use this again on a more day-to-day level with a more integrated setup (basically how can I use this all the time, instead of just every now and then).

Welp, thankfully I did some test transfers on like 50GBs of data. This data transfer has a good distribution of all sorts of file types; videos, images, big and small files alike.

I got this

I have a bunch of files that were randomly corrupted during the copy transfer. These files and folders are also unable to be deleted when I lock and re-unlock Cryptomator.

Security is one thing. But there is no point in security if you obliterate your own files… what about files that are as important as your passphrase keys? Pretty much never going to use this again, and will also recommend anyone I talk to and know to never touch this program for they will eventually have precious data destroyed because of this program.

Thanks for making this post @CrypotBFI and confirming my experience.

I’m only a few days into using Cryptomator and unfortunately, I’m having data corruption issues as well.

I was only just getting started setting up two initial vaults, I was copying in very basic office documents and jpgs when I started receiving directory and file location errors. One vault is now corrupted, not allowing me access to move/rename/copy/open anything at all. I have a few directories that have somehow been renamed and Windows now displays the directory names in Chinese.

Obviously this is beyond a simple bug I could overlook.

Cryptomator 1.3.3
Windows 10 Home 64-bit


I am also an new Cryptomator user and experiencing same behaviour. At the moment only 3 files have been identified as corrupted (I can’t delete them file is declared as “not found”, and another has special / Chinese charaters)

I noticed this corruption when trying to sync the vault content towards a USB backup key, with FreeFileSync, which I am using for a while without any issue.
The final log from the sync says 3 files could not been copied / moved.

I am concerned.

Cryptomator 1.3.3
Windows 10 Home 64-bit

Even though this has nothing to do with the original question, I’d like to add some info regarding the “weird special characters”.

[…] We’ve done some extended testing and we believe that “long paths” are the issue. We don’t know the threshold and we don’t know if this is a new issue in Windows 10 (with some update) or if it has been like that for a long time.

We were able to reproduce the issue with a “regular” WebDAV server like So it’s definitely a bug in Windows Explorer’s WebDAV client.

Another workaround would be to shorten your paths since Windows doesn’t deal with them well. Ultimately, this can only be fixed by Microsoft or at the latest when we switch to another filesystem with Cryptomator 1.4.0.