Not able to connect onedrive - Application 'b57...' is disabled

My mobile APP is working for half a year now. After the last update I cannot connect to my onedrive.

I get the error message:
AADSTS7000112: Application ‘b57c3880-c857-4588-b02e-5da3c5b2174c’(Cryptomator for Android) is disabled.

What to do?

Hey and welcome :slight_smile: ,

What version of Cryptomator do you use (you can find this at the very bottom in the settings)?
Where do you find this error message?

You help us the most to find the error by sending us the log file.

Thanks!

My App-Version is 1.3.10.
My reference in the debug log email is the title of the post here.

Thanks for the log file.

Where do you find error message of your start post?

From the Cryptomator log I can only find out, that we get the following message as response to the login request from Microsoft: The user cancelled the login operation. From this side it doesn’t look so bad because I think at any point, you canceled the login attempt, right? But we need to find out what happened before.

What I do:

  • Start the cryptomator app
  • click + to add an exisitingvault
  • choose OneDrive
  • enter my username and password and a sms send my microsoft
  • run into the error message

Thanks for the hint.
We will find out the problem and publish the result.

Thanks for your patience.

Unfortunately I haven’t been able to find a cause for the problem yet.
I’m assuming it still exists, right?

Yes teh problem exist.
Can it be that this is related to access rights in one drive. There is a settings where I can allow or disallow app’s to use one drive. Maybe this is the reason. I had another tool which has access to one drive directly and this tool is listed here

Yes that can be but have no idea why there is no entry in your account for Cryptomator :thinking: .
My settings look like this:

Just a question @cryptuser234 as this is not clearly described:
Is it possible that you have deleted the Cryptomator app permission within OneDrive?
Can you look in OneDrive Settings at „My Apps“ if the Cryptomator app is listed there and if yes can you grant the permission again? (As it is shown in the text of your screenshot)

Usually the permission for an app is granted again every time you connect to OneDrive. Maybe for what ever reason this is prohibited and you’ll have to grant the permission for the Cryptomator app manually again.

I checked this and the app was listed there, as netdrive app.

for testing and trying to fix the error I deleted the app from here and hoped that it will reappear if I start the cryptomator app again. But this does not happen. Can I add the app manually the the allowed apps?

Normally the name should be “Cryptomator for Android”, is it possible that you used before http://www.netdrive.net/ or something similar? But it is really strange that our app isn’t listened.

Edit: When you setup the OneDrive connection, do you see this message?

Should the message be seen in the one drive app on the smartphone or inside of the cryptmator app or a parallel logged in session from a PC to one drive?

If I deactivite the one drive app on my smartphone. it does not change the behaviour. on a parallel running session on my pc at one drive, no meessage will pop up.

If you login into Cryptomator for Android the first time there is the normal login screen and after that, this permission request dialog. You will be directly redirected by Microsoft after the successful login to this permission request page.

What you can try is to clear the complete storage of Cryptomator for Android (System settings --> Apps & Notifications --> Cryptomator --> Storage --> Clear Storage) and setup OneDrive from scratch. Maybe this could help. But be aware that after clearing the storage you have to setup all vaults again