Issues with Vault on smb mounted Fritz.Nas HDD

Hey there

I ran into an issue to which I couldn’t find a solution. It seems similar to this(Unstable and slow if vault is on a FRITZ!Box NAS. · Issue #2276 · cryptomator/cryptomator · GitHub) and this(Can't upload any files to vaults (error splicing file)).

I’m running xfce Version of Linux Mint 21.2 (Victoria)
The cryptomator vault is located on a HDD hooked up via USB to an AVM Router (Fritz!Box 7430 running Fritz!OS 07.31).
I mount it via terminal using ‘mount.cifs // -o username=NASUSER,domain=WORKGROUP,noserverino,uid=$USER /mnt/NAS’
Then I open the cryptomator vault.
Working with .md and .pdf files is not an issue at all. But as soon as I copy an image file into the vault, the file gets corrupted. When I try to open the image file in xViewer I get an Input-/Output Error. Only thing I observed is that image files roughly double in size when copied to the vault.

I already tried different smb versions and different mount flags(cache=none,nobrl,file_mode=0777,dir_mode=0777,uid=1000,gid=1000) and mount points(/mnt and /media/user).

Also I tried different Volume Types (FUSE, WebDAV(gio), WebDAV(http)) with no success.

It did work when I was using Ubuntu JammyJellyfish with Nautilus so maybe it’s a Thunar issue?
Did any of you experience the same issue and found a solution? Any tips on what I could try to solve this problem?

Thanks in advance!

Also, smb is veeeeeery slow.