Is Cryptomator monitoring the Clipboard?

Hi there,
On the weekend I tried out Cryptomator and I like it pretty much!
but when I copied a password from Paaword Safe to Cryptomator I received a warning message, that Cryptomator is monitoring the Clipboard and therefore it is not safe to use the Clipboard for passwords.
I have a PC with Win10Pro.

Can someone explain to me why Cryptomator is doing that? (honestly this was not really building up trust, but I guess there is a good explanation for that behaviour…)


Thanks for the feedback.

Maybe more or less related to Cryptomator requesting keyboard input monitoring on Mac but no, we don’t actively monitor the clipboard. As @tobihagemann found out in the other thread, it seems that this is a JavaFX bug :man_facepalming:

thanks for that explanation!
If it really is a Java Bug, do you think that this bug will be fixed sooner or later?

The only thing I wonder is, that in the topic you referred to the keyboard input is mentioned.
In my case it is the Clipboard. Isn’t that something totally different?

Actually yes. But i think in the end it is the same reason: A “bug” (not sure if one should call it this way) in JDK/openJFX.

Do you have any Anti-Virus software installed on your computer? (e.g. something from Symantec) I see this warning for the first time. And there is also this sentence in the warning that confuses me: “Es ist auch möglich, dass noch weitere Anwendungen die Zwischenablage überwachen” (translation: “It is possible that further applications monitor the system clipboard.”)

You can accquire a reference onto the system clipboard in openJFX, but a quick search only revealed this useage in the upcoming 1.5.0 version. Maybe @overheadhunter knows another usage in the code?

1 Like

Due to my bad brain I am using the “Password Safe” from Mateso.
Obviously this Software is checking the system for nosy applications before is puts Passwords into the Clipboard.
The error message appeared when I tried to copy a password to Cryptomator.

This is the software version I use: Anmerkung%202019-12-03%20063612

Reordering vaults uses the drag’n’drop API, which is closely related to the clipboard. Either this or a more general a-priori permission grant for the whole JFX toolkit causes it. To verify the latter, we might try to use the new test application? :slight_smile: