iOS OneDrive Connection Broken. Authentication fails. Browser not allowed

I cannot say since when this does not work anymore, but I cannot open my vault from any of my iOS devices anymore!

Regardless if I use the right or a wrong password, the App stays in the “Unlocking” state, where the turning circle is shown.
And that’s it.

I’m locked out.

The Vault lies on my OneDrive storage.

Any idea?!?

Same issue here.
The connection “lost” its credentials.
And if I try to set up the connection new, Microsoft authentication says that “this browser is not allowed to access the Ressource”
(See screenshots)

So the iOS app works well, but the OneDrive authentication is broken.

I was able to confirm the issue that “forgotten” sessions (probably happens when you haven’t logged in for a while) can cause issues. However, logging out of OneDrive and then logging back in (inside the Cryptomator settings under “Cloud Services”) worked in my case. Not sure what the “second” issue is all about…

Additional investigation.
Due to the message I posted, office365 login does not allow other “browsers” than Safari, Edge and Intune.
I tested that.
Opened chrome on iOS and tried to log in. Same error.
Opened safari on iOS and tried to log in. => OK
Opened chrome on Windows and tried to log in => OK.

So the question is: is there a way that cryptomator (iOS) can be forced to use safari for the login process? Could that be a solution?

Important PS:
I’m not sure if this is a cryptomator issue at all. I suspect the IT department made some changes to the configuration of office365.
Today I opened the iOS OneDrive Client and received this message:


“Your IT administrator now supports you in protecting business, school or university data in this app.”
(what a joke)
This is also new and at least suspicious in combination with this issue.

I could not get this fixed.
I even removed the Vault and then added it again.
No success.

Even if this effect comes from some problem with OneDrive or it’s authentification, it seems that Cryptomator just does not show the required login mask or something similar.

That more than frustrating.

Please go into Cryptomator’s settings (the gear icon at the top right), tap “Cloud Services”, and then “Sign Out” from / “Log In” to OneDrive.

In any case, we’re looking into this issue and work on a fix. In the meantime, the workaround should work in most cases. We’ll also look into the other issue reported by @Michael.

1 Like

This did help indeed!
I never came to that idea.

Many thanks!

Note: Cyberduck access is working. so for my case it seems not to be a general prohibition of third party software access to the business cloud.

I now have removed the existing cryptomator iOS permission from my onedrive account and tried to set up a new one by settingh up a new connection via iOS.
No success. Its still complaining that the used browser to perform the login is not allowed.

Is anyone out there who is using OneDrive for business and not having problems with the iOS access?
As this problem still exists for me, I’m wondering if this is a general problem with OneDrive4Business, or just caused by an overzealous IT Admin at my company.

We just released a beta version of 1.4.1 via TestFlight, which uses the new OneDrive libraries under-the-hood. Does that work for you now, @Michael?

1 Like

Yes, the connection to OneDrive4Business works again with the beta.
Thank you!

1 Like

I just updated on my iPad, and bammm: “Unsupported URL” message after entering the OneDrive password when entering the vault password.

1 Like

I removed the vault, added it again as existing vault - and then everything worked!

But this will cause much frustration, as not all come to the idea to try this sequence!

We’ll look into it. Thank you for reporting it!

Edit: We found the cause, will release a fix asap.

1 Like

Great to hear :slight_smile:

Just an information:

After i reopened Cryptomator again, the error about the unsupported URL did rise again.
So the removal does only help one time …

Fixed!
Everything works like a charm!

Many thanks!!! :slight_smile: :slight_smile: :slight_smile:

2 Likes