How do I enable Recycle Bin for the encrypted files?

os:windows

#1

On Windows, Cryptomator volumes are mounted as network (WebDAV) drives. By default, Recycle Bin is disabled for such drives which means that the files you delete are gone immediately. However, it is possible to enable it using a registry tweak for each vault:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{9147E464-33A6-48E2-A3C9-361EFD417DEF}]
"RelativePath"="B:\\"
"Category"=dword:00000004
"Name"="BDrive"

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\BitBucket\KnownFolder\{9147E464-33A6-48E2-A3C9-361EFD417DEF}]
"MaxCapacity"=dword:00000400
"NukeOnDelete"=dword:00000000

Modify the following parts in the sample above to suit your needs:

  • Generate a unique GUID for each Cryptomator vault.
  • RelativePath - substitute the letter of your drive here.
  • MaxCapacity - desired Recycle Bin size in MB (in hexadecimal, e.g. 0x00000400 is 1024)

Deleted files are moved into the $RECYCLE.BIN folder on the same drive so they will still be encrypted.

More information: https://social.technet.microsoft.com/Forums/windows/en-US/a349801f-398f-4139-8e8b-b0a92f599e2b/enable-recycle-bin-on-mapped-network-drives

Step by step

First open Registry Editor by pressing Windows + R, then type regedit and press enter.

1.

2.

3.

4.

5.

and reboot.


#2

Hi,

I am not really familiar with computer commands.

I found my way up to
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\

but could not find {9147E464-33A6-48E2-A3C9-361EFD417DEF}]

Found [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\BitBucket\

but not KnownFolder{9147E464-33A6-48E2-A3C9-361EFD417DEF}]

Should I create those and how in details with size of the Bin ?

I have 2 vaults/drives (Z:) (Y:) I would like recycle bin enabled.

I use Windows 10.

Thank you for your help.

Pierre Marie


#3

Modified some parts of the guide and added a batch script, which you can use to automatically enable the Recycle Bin. You only have to enter the drive name of the vault (in your case, fist run Z:\ , second run Y:\ ) and the max capacity of the Recycle Bin (in decimal).

If you want to enable it by hand, you have to create complete new entries. Each vault needs an new GUID:
Replace the 9147E464-33A6-48E2-A3C9-361EFD417DEF with a GUID generated from the tool linked in the guide above. Then create the entries with your generated GUID, insert the values from the guide and you’re done.


#4

Dear Julian,

Thank you for your quick answer.

I runned the batch script and I think I did it fine.
I restarted my pc.
I erase 1 file in each vault to test but I cannot find the Bin in any of the vault.


#5

I copied it from the link above, changed some parts and tested it and it worked, but can not explain why it worked because the code contains directly after getting the MaxCapacity from the console, errors. The good and the bad is that the script has done nothing…sorry for that :smirk:.

Please try again to use the manual mode.


#6

I tried manuel but some details seem out of reach for me :slight_smile:

Thanks.


#7

Wrote an short step-by-step guide, hope it helps :blush: but to be honest, it’s not that user friendly^^

We are discussing to integrate an “Windows-Recycle-Bin-enabler” directly into Cryptomator…well see, maybe there is in the future a button to handle that :thinking:.


#8

I think I did it right, looks like what you show but still can’t find any recycle bin … Wait for better improvement. Thank you?


#9

“…We are discussing to integrate an “Windows-Recycle-Bin-enabler” directly into Cryptomator…well see, maybe there is in the future a button to handle that.”

Any news ?

Bin is of great value.

x


#10

Hey, you said, you’ve created a batch file.
Could you publish it again?

Thanks!


#11

Bonjour Pierre Marie

Did you find the answer to your question ?

"but still can’t find any recycle bin "

Let me know, I just did the Registery change and it works - On Windows 10

Regards

I speak French by the way, in case…


#12

Bonjour Alibabas,

Merci pour la réponse but I did not find a way to enable the bin.

Do you mean it is possible now to have a bin in a vault ?

Great you speak french.

Regards.


#13

Hi Pierre

I am not an expert, I simply followed the steps described in the Discussion, decribed by mkatsevVR.
Where are you blocked (Which Step ?)

I did an example
My vault is assigned to drive "Y"
When you delete a document from the Vault, the deleted document is moved into the Recycle Bin from the Vault

1 - Vault and its recycle BIN

2 - Folder / File from the vault to be deleted

3 - File is encrypted and moved to the vault (this step and the corresponding encryption process is described into some other discussion from the forum, but I don’t understand the benefit of encrypting the document knowing that you can’t “read” it or restore it and most of it it’s stored in the Vault recycle bin. Therefore, protected by the Vault encryption)

4 - As I said I am not an expert, hence I have simply noticed that the deleted document is also available in the “general” recycle Bin accessible into the Explorer section “Quick Access”

I can see my File name and I can identify the original Driver and most of it, I can restore it !

Let me know if this helped you

Regards
P.S: as a new user, I can only post a single Screen shoot, I’ll combine all of the in one.


#14

dear Alibabas,

Thank you for your answer.

I think I am stuck with first step.
There is no recyclebin in my vault, not before I delete a file, no after deleting a file.

Question is, how did you enable the recycle bin ?


#15

I tried again manual step by step process to enable recycle bin but nothing happens but worse it blocked some stuff in windows settings and I could not rename folders after fulfilling the steps.
Fortunately I could reverse and erase what was created through the steps.

It is frustrating and a real problem not to have recyclebin enabled to avoid erasing files for ever.

All help welcome.

thanks


#16

Would be cool if the trash would be as an extra function for Cryptomator implemented. Which could be enabled with a simple option.


#17

I am now testing cryptomator 1.4 Beta2. Previously I have setup a Recylce Bin using WebDav connection, but now using cryptomator 1.4 Beta2 I can not get the Recylcle Bin to work, using either FUSE or DOKANY. Is it or will it be supported with FUSE or DOKANY connection?

I really like to having a small Recylcle Bin just to catch some accidental deletes which occur every now again.

Regards


#18

Under ubuntu, you already have a built in recycle bin (the .Trash directory). I dunno the situation under other linux distros.
For windows, the the dokany project (which cryptomator is using for mounting the vault) has an option for an recycle bin, but currently it is deactivated because it causes some problems. Maybe in the future it is included as an option.
Until then under windows you have to stick with WebDAV or find some way other neat trick to get it working.