Getting asked for password frequently

Hi,

Since the last update of Cryptomator to v1.5.8 on my Android 10 Motorola One Vision I get frequently asked to enter my Vault password even though I have Fingerprint unlock activated. I use OneDrive as the cloud service.

Once I have the Vault unlocked with the password I can unlock it with the fingerprint for a while. But if I don’t use the app for a few hours it asks me for the password again. Same happens if I force close the app then it requests the password too when I open the app again. I’m guessing this may be related to power saving on the phone?

In any case it did not happen before the last update so I assume something changed.

Is this expected behaviour or a bug?

I’ve already tried removing the vault and adding it again but still the same issue…

Thanks for your help!

Checkout my thread HERE.

A handful of bugs reported, logs sent, and eager to help close bugs. A moderator has been kind enough to drop by some 3 times, and that’s it. We might be the only two active users right now. Not to dissuade you from participating, but I’m worn out holding my breath.

As it is, Cryptomator for android is not reliable. Exporting function is so delicate you’d be doing your future-self a service by not uploading anything.

Desktop clients work well and they’re free, everyone should continue using them exclusively.

1 Like

This is not expected behaviour.

We switched in v1.5.8 from the FingerprintManager to the biometric-auth library, which also supports other biometric authentication mechanisms like face unlock.

Unfortunately we didn’t notice it during testing and during the > 2 weeks beta our test-users didn’t notice it either. We’ll look into it, thanks for reporting!

1 Like

I’ve been an Android user for over a year and everything including the fingerprint reader has always worked perfectly for me. We’re out here, most of us just have nothing to complain about.

Mike

1 Like

Did I understand you correctly:
Once you have the Vault unlocked with the password and this vault is locked again you can unlock it with the fingerprint for a while but when it wasn’t unlocked before due to force close or long time not used the enter password dialog is displayed?

Can you please send us your log file after reproducing it?

Because currently we’re unable to reproduce the problem and the log file should bring some light into this topic.

Yes that’s correct.

Have just sent an email with the log attached from within the app.

Btw… What I just discovered while reproducing the issue…

If I press cancel on the password prompt and then press on the vault again to unlock it comes up with the fingerprint request.

Very odd :thinking:

Ah I see thanks for this hint. It’s related to the onedrive unlock process together with the biometric auth, can reproduce it and we’ll provide a hot fix ASAP.

Thanks again for reporting :+1:

1 Like

Took a while but we solved the problem. Here you can find some more information if needed:

2 Likes

Great work! Thanks for the effort :grinning:

New v1.5.9 just arrived on my phone. Now everything seems to be working correctly again. No more password promts :+1:

Thanks again!

2 Likes

A month has passed and I still have no clue as to the purpose of this response.

Good for you?

That should do it.

The implementation is still broken, 1.5.9 is just a bandage.

Notice how it fails when unlocking on a fresh start, quickly followed by a working prompt.

In your case it doesn’t fails, it is just canceled by us, read more:

If the biomatric auth dialog isn’t cancelable on a device like @bluezed’s new device, you can disable the preloading of the masterkey.cryptomator-file which will be available in 1.5.10 soon:

© 2020 Skymatic GmbH • Privacy PolicyImpressum