Failed to launch JVM after Windows 10 Update?


I now get the ‘Failed to launch JVM’ error and Cryptomator refuses to start.

What i did so far:
Uninstalled Dokan. Rebooted. Uninstalled Cryptomator. Rebooted.
Reinstalled Cryptomator+Dokan do latest versions. Did not help.
Uninstalled Dokan again. Rebooted. Uninstalled Cryptomator again. Rebooted.
Reinstalled Cryptomator 1.5.11 (older version) with the included Dokan. Did not help.
Uninstalled Dokan. Rebooted. Installed only the new Dokan drivers. Did not help.

I came across Failed to load JVM where to start from the slightly modified builtkit (1.5.12) with the added command for launcher-win.bat. There i can start Cryptomator and open my existing vault.
But this is not so practical, because the CMD window and the Cryptomator needs to be open in the “forground” all the time.

I also thought maybe it has something to do with a windows update. Because after the reboot with windows updates the ‘Failed to launch JVM’ stuff started. So i tried to delete the updates that are uninstallable. Did not help.

Since i am no programmer and no developer i have 0 clue how to fix that.

My PC:

      Time of this report: 2/12/2021, 06:00:43
         Operating System: Windows 10 Pro 64-bit (10.0, Build 19042) (19041.vb_release.191206-1406)
                 Language: German (Regional Setting: German)
      System Manufacturer: Gigabyte Technology Co., Ltd.
             System Model: X570 AORUS ULTRA
                     BIOS: F32 (type: UEFI)
                Processor: AMD Ryzen 9 5950X 16-Core Processor             (32 CPUs), ~3.4GHz
                   Memory: 65536MB RAM
      Available OS Memory: 65480MB RAM
                Page File: 5462MB used, 69745MB available
              Windows Dir: C:\Windows
          DirectX Version: DirectX 12
      DX Setup Parameters: Not found
         User DPI Setting: 96 DPI (100 percent)
       System DPI Setting: 96 DPI (100 percent)
          DWM DPI Scaling: Disabled
                 Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
 DirectX Database Version: 1.0.8
           DxDiag Version: 10.00.19041.0546 64bit Unicode

What can i do?

Welcome to the Cryptomator Community :slight_smile:

in your os the Java Access bridge might be enabled. For more Info and how to disable it, see Failed to launch JVM.

Well since i am not total unfamiliar with computers and windows os, i manage to find the mentioned JDK folder (that software did not display where it was installed…) and i applied the command and now it works.

I can only imagine that others will suffer from that issue because they have no idea what all that means.

Thanks for it so far. I still dont know why all of a sudden that problem came up.