Failed to launch JVM

Error Description

When starting Cryptomator, only a small Window appears stating “Failed to launch JVM”.
failedToLaunchJVM

Reason

Java offers with Java Access Bridge an Accessibility API so that software written in Java (like Cryptomator) can be used with Helper programs like Screen Readers, Magnifiers, etc… Unfortunately enabling this feature in Java prevents Cryptomator from starting with the above error message.

Solution/Workaround

Disable Java Access Bridge. Run the following command (where %JDK_HOME% is the directory of your JDK) from a terminal:

%JDK_HOME%\bin\jabswitch -disable

Note that this is a user or system wide disabling, thus applications like

might not work as expected afterwards.


Sources: https://docs.oracle.com/javase/8/docs/technotes/guides/access/index.html

2 Likes

This was my problem. I tried so many other fixes, but to no avail.
Note: disabling the Java Access Bridge from Control Panel’s ‘Ease of Access’ center in Windows 10 did not do the trick. Only by running the commandline switch on the correct version of ‘jabswitch.exe’ worked. The %JDK_HOME% variable wasn’t set in my system either, so I had to find the executable’s location on my own.

© 2020 Skymatic GmbH • Privacy PolicyImpressum