Error Code GIJU:E215:E215

I opened an old archive and it needed to be upgraded and received the following error:

Error Code GIJU:E215:E215
org.cryptomator.cryptofs.migration.api.NoApplicableMigratorException
	at java.base/java.util.Optional.orElseThrow(Unknown Source)
	at org.cryptomator.cryptofs@2.4.1/org.cryptomator.cryptofs.migration.Migrators.migrate(Migrators.java:101)
	at org.cryptomator.desktop@1.6.10/org.cryptomator.ui.migration.MigrationRunController.lambda$migrate$3(MigrationRunController.java:123)
	at org.cryptomator.desktop@1.6.10/org.cryptomator.ui.common.Tasks$TaskImpl.call(Tasks.java:140)
	at javafx.graphics@18.0.1/javafx.concurrent.Task$TaskCallable.call(Task.java:1426)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.base/java.lang.Thread.run(Unknown Source)

Any help would be appreciated.

Welcome to the Cryptomator Community :slightly_smiling_face: ,

the solution can be found in the thread Migration fails.

In short: Over time Cryptomator changed the definition how a vault is structured (called vault format). The desktop app offered/offers migrations from older version, but only to a certain older version. Yours is so old, you need older versions of Cryptomator. Just read the linked thread.

© 2022 Skymatic GmbH • Privacy PolicyImpressum