Disk open error created

I have a mac notebook with 10.11 system when opening the cryptomator disk I get this error:

java.lang.IllegalStateException: Already unlocked.
	at org.cryptomator.common.vaults.Vault.unlock(Vault.java:131)
	at org.cryptomator.ui.unlock.UnlockWorkflow.attemptUnlock(UnlockWorkflow.java:107)
	at org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:90)
	at org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:44)
	at javafx.concurrent.Task$TaskCallable.call(Task.java:1425)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.base/java.lang.Thread.run(Unknown Source)

Cryptomator versione : 1.5.11

how can i fix this error? There is a solution?
Thanks for your help

1 Like

Hi, I just got the same error and solved it by restarting the PC. Try that.

If you get in, could you please try to copy some recently uploaded files from your vault? I cannot access them (see my topic).

thanks for the tip, I solved it as you said


So are you able to read some recent files?

This specific issue is also on our bug tracker (and already fixed):

But as noted in the comment, from the user point of view the real issue is, that the vault is not accessible in the first try. As the OP wrote the issue appeared on MacOS, i suggest to look at those threads: