Cryptomator for Raspberry Pi

I have recently been exploring using a RPi4 as a desktop. The challenge has been finding ARM compiled versions of the applications I use on my PCs. I was wondering if there was any plan to compile the Cryptomator desktop client for ARM Linux?


Nathaniel Fink

1 Like

Unfortunately the Java UI used by Cryptomator is not supported on ARM systems, so it can not be compiled.

There is a command line version called cryptomator-cli which previously worked on ARM, but its currently not supporting the new vault format.

If Cli gets updated, raspberry support would depend on a number of things, eg the provided ARM version of java in Raspbian or whatever distro you are using being compatible.

I too hope one day to see Arm support, as im now doing 75% of my desktop stuff on a Pi4!

If your looking for local file crypto, you can set up Ecryptfs on your home dir-theres pleanty of guides about, but obviously this wont work for your cloud files.

The first thing I tried was Cryptomator-CLI. I had previously got that running on a different machine for Dropbox. But it looks like it hasn’t been updated since 2017.

I tried compiling the cryptomator-develop project using jdk 14 and I think JavaFX. It initially gave me errors but compiled to the end. But when I tried to run it with the linux launch bash script, I got the following error (JavaFX missing). I take it that’s what you were referring to.

Exception in thread “main” java.lang.NoClassDefFoundError: javafx/beans/binding/Binding
at org.cryptomator.common.CommonsModule_ProvideScheduledExecutorServiceFactory.provideScheduledExecutorService(

We released today a new version of the CLI project, which allows to unlock vaults over the terminal:

1 Like

So, the CLI will work on a Raspberry PI, but still not the standard application GUI?

To my knowledge, yes. See also this issue ticket on our tracker:

I made a small research and the most recent posts regarding JavaFX (the graphical framework used in Cryptomator) and ARM are from 2018 and report some experiments, but nothing stable.

A short update:
JavaFX is now available for ARM architectures on unixoid systems. Hence, it is possible now to build Cryptomator for the raspberry pi :slightly_smiling_face:


@infeo this is wonderful news for me, as i use a pi as a low powered desktop.

ive tried building this a number of times on a pi4 running raspios since 1.6.0 , but always get the same error detecting the platform. I see in the maven repos- arm32 and aarch64 builds.

maven with the -X flag detects the platform as

OS name: "linux", version: "5.10.63-v7l+", arch: "arm", family: "unix"

Is there a compile flag or setting somewhere that could help maven find the correct files?

Could not resolve dependencies for project org.cryptomator:cryptomator:jar:1.7.0-SNAPSHOT: The following artifacts could not be resolved: org.openjfx:javafx-base:jar:${javafx.platform}:, org.openjfx:javafx-graphics:jar:${javafx.platform}:, org.openjfx:javafx-controls:jar:${javafx.platform}:, org.openjfx:javafx-fxml:jar:${javafx.platform}:, org.openjfx:javafx-swing:jar:${javafx.platform}: Failure to find org.openjfx:javafx-base:jar:${javafx.platform}: in was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced

Edit: added platform detection from log

I’ve been testing this on a Pi4, with 2 operating systems. RaspberrypiOS 64bit (manually built) and Arch linux using the AUR repository script.

in both cases vaults can be created and unlocked using webdav, but “revealing the vault” in FUSE gives an input/output error.

I have tried with the default unlock path, and also by making an empty folder in home, then specifying the unlock location. no files are shown in the folder when browsing to it manually in a file manager.

Using “ls” on the parent dir, the locked and unlocked folders shows as

drwxr-xr-x 3 pi pi 4096 Feb 3 21:48 asdf
d??? ? ? ? ? ? asdfunlocked

I’ve also had FUSE issues with cryptomator-cli on armhf and arm64 ,but they work fine on x64. - Wondering if there is an issue with the fuse adapter working on ARM?

Yes, but we’re working on new FUSE bindings with ARM support. More details in the linked issue