Can't get cryptomator to work after moving to new iphone with iOS 17

Hi there,

I can’t get cryptomator to work after moving to a new iphone with ios17

I saw an earlier post but the suggested remedies don’t work for me. I am using both icloud and Dropbox. I’ve tried numerous things

  • In cryptomator: went to Settings → Cloud Services and removed the service and then added it again
  • In cryptomator, for each vault did a ‘Remove from Vault List’, then added it again
  • deleted the cryptomator app from the iphone, re-added it and then tried to add the vaults again

All had the same effect, the password when adding the vault was accepted but when trying to open the vault, upon ‘unlock’, I received either of the following error messages

Any idea?

Error The operation couldn’t be completed. (CryptomatorCom-monCore.CloudProviderAccount-Error error O.)

Internal error RBSLaunchRequest error trying to launch plugin org.cryptomator.ios.fileprovider-ui(…): ErrorDomain=RBSRequestErrorDomain Code=5 "Launch failed."UserInfo={NSLocalizedFailureRea-son=Launch failed.,NSUnderlyingError=0xb2ed213c0{Error Domain=NSPOSIXErrorDo-main Code=2 “No such file or directory” UserInfo={NSLocalized-Description=Launchd job spawn failed}}}Cancel

(I replaced the fileprovider-ui with … in this post)

Had the same problem, and deleting the app, reinstalling it, and signing back in got it working for me. Sorry that’s not working for you!

I contacted support and will report back once a solution is found

To be honest, I’ve never seen something like “Internal error RBSLaunchRequest”. And there are not many results when googling it.

Is it right that you don’t even see the screen, where you can enter a password? The error suggest that the FileProviderExtensionUI is unable to launch. If that’s the case, this seems to be a deeper bug in iOS. And it’s a brand-new iPhone without any customizations?

I could see the screen to enter the password, was able to enter it and it was accepted.

In the meanwhile, I was able to resolve the issue by first uninstalling / reinstalling cryptomator and then forcing a download - via the file app - of the respective folder that hosts the cryptomator vault. Maybe even just the latter step would have sufficed. I don’t know. I saw the tip in an older post

Since it is a new iphone, the data for the vault apparently hadn’t been downloaded yet completely to the iphone.

Thank you RenaldoX,

I just upgraded from iPhone 13 to iPhone 15 and was experiencing the same problem. Forcing a download - via the file app - of the respective folder that holds the crytomator vault did the trick for me.

Thanks again.