Cannot rename folder after creating it error 0x8007045D


I’m new to Cryptomator and testing it for a possible rollout within our company.
I’m running into an issue and wondered if someone can let me know if this is normal behaviour, please?
I have a shared folder on Dropbox synced to my PC (Windows 11), in that share I have created a vault and mapped it to the drive letter I: Each time I create a new folder under the I: drive Windows automatically names it ‘New Folder’, when I over type this, or try to rename it to something else I receive the error message 0x8007045D The request could not be performed because of an I/O Device error.
If I wait for about a minute, I can then rename the folder. My assumption is the folder is locked while it is being encrypted, and maybe due to the syncing with Dropbox, but this is just a guess. I know the staff won’t understand this and it will find it frustrating.
Is this normal behavour or is there something going wrong?
Any help will be appreciated.

Edit: 2022-12-23 14:54
I created a vault on the local C drive, not synced with dropbox and the above mentioned behaviour did not occur. I was able to create the folder, overtype the default name New Folder and then rename it again without any errors. The error reported above must have something to so with syncing to Dropbox. Does anyone know if this issue can be resolved?

Edit: 2022-12-23 21:40
Just an update: This evening I created a New Folder and was able to rename it without the error appearing. I repeated this 3 times and renamed the folder again after it had just been renamed, each time it worked as desired and didn’t cause an issue. The only difference I can see between doing it this evening and this afternoon was during the afternoon I had a number of large files (1.5GB approx.) syncing at the same time as the creation of the new folders, presummably creating a queue and blocking the I/O. This evening all the files were in-sync and Dropbox was indicating ‘up to date’.
I’d still like some input here from anyone that can clarify why the issue occurs. Our staff won’t be as logical when creating folders, if it throws an error they will call me or start trying to create more new folders. A better error message would be great, if the app could identify the cause.

Hey and welcome to the Cryptomator Community :slightly_smiling_face:,

Cryptomator on the desktop does not communicate directly with the cloud but with the local file system. In this case, the Dropbox sync client takes care of the synchronization, which in turn knows nothing about Cryptomator. All calls here from Cryptomator go against the local file system.

Maybe we can check another thing: If you look under Cryptomator → Preferences → “Virtual Drive”, what does it say under “Volume Type”? WebDAV? If so I would try to install Releases · winfsp/winfsp · GitHub, change it to FUSE and see if you can get this reproduced again. FUSE is more stable than WebDAV to mount the vault folder into the file system.

Hi SailReal

Thanks for your response.
My virtual drive was already set to FUSE, I’m running version 1.6.17 (msi-4104).
I’m sure the problem was due to the background processes queuing up due to the large file sizes and a large number of files being synced to Dropbox. The problem was only present when that happened, so I can expain that to our staff when they are downloading a large shared folder.


1 Like

Thank you for testing and sharing your findings with us.

Just out of curiosity, can you reproduce it without Cryptomator, directly in the synced Dropbox folder?

Hi SailReal

I didn’t test that, but I will be moving another Dropbox shared folder to a new location soon, which will involve syncing lots of files, so I’ll be able to test it then, and I’ll update this post afterwards.

1 Like

I have a FUSE Cryptomator vault in a pCloud drive that I access from 3 different devices (an Android phone phone, a Win 10 Pro desktop, and a Win 10 Pro laptop).

One day I noticed that modifications I made to two particular files (we will call them x-file and y-file) on my desktop or phone would correctly update between the desktop and the phone, but they were not getting updated on my laptop. I’m not sure if it is because x-file and y-file were open on my laptop when Windows decided to apply and update and reboot the laptop, or perhaps it was something else I’m not aware of.

Curiously however, if I modified x-file or y-file on my laptop, the files would get updated on the phone and desktop.

In other words, the laptop could push modifications made to x-file and y-file to the Cryptomator vault in pCloud, but the laptop is unable to pull modifications (made by the desktop or phone) from the vault in pCloud.

As I started conducting experiments I noticed duplicates of x-file and y-file appear on the laptop, with the exact same filename and the exact same outdated modification date. The phone and desktop however still correctly showed only one x-file and one y-file.

From the desktop I decided to move x-file a y-file to a new folder. When I went to the laptop to see what happened, one x-file and one y-file now correctly appears in the same folder the desktop moved the files to and with the correct modification date finally attached to the files. However, one outdated version of x-file and one of y-file still remain in the old folder location on the laptop.

When I attempt to delete the old files I get an 0x8007045D error. Specifically the error reads “An unexpected error is keeping you from deleting the file… Error 0x8007045D: The request could not be performed because of an I/O device error.”

I also get the same error if I try to rename the files or move the files to a different folder.

What can I do to delete these files?


First of all, you have the same issue as the topic creator and you already posted your problem in this topic. Which was perfectly right. I dont get why you descided to delete your post and start a new topic with the exact same error message and problem. So I moved it back again. Please do not open new topics for already existing issues. The topic author might benefit from the information gained out of your problem, and others will have all information in one topic.

Second: although I dont know what might cause your I/O error, you can try to access your vault directly online on pCloud and try to delete your files directly online. Maybe the sync client does then also delete the local files as well.

Thanks for the suggestion and sorry for the second post. After more than a day of the post not receiving any response (I certainly get impatient some times!) I decided maybe it would be seen if I posted it separately. Lesson learned. I’ll give your suggestion a try now.

I accessed the vault with Cyberduck (unfortunately had to disable pCloud 2FA!), but it did not work. The vault accessed via Cyberduck shows exactly what the Cryptomator vault on my desktop and phone show; it does not show the duplicate files on my laptop that I am unable to delete.

Any other recommendations how I can get these files off my laptop? I have tried uninstalling and reinstalling Cryptomator, but the files remain. Are they stored in some sort of cache on my laptop?

Mhm. Weird. What I would do now

Most important: do a backup. !!

  1. switch the volume type in the vault settings to any of the available options.
  2. restart cryptomator
  3. open the vault and check if you can delete the unwanted files
  4. if not, close the vault and go back to 1 and try an other option.

You should try every option that available. Especially WinFSP. If this option is not available, install WinFSP (latest version 1.x) or re-install cryptomator which will also install WinFSP.

If this does not help, then.

  1. run a disc check to make sure there are no hardware errors. If there are, try the „repair“ mode that is offered after the check.
  2. open the vault and see if the unwanted files are still there and if yes try to delete again

If this does not help then you can rebuild you local vault from your online files.

  1. make sure your vault is completely synced online
  2. disable the sync
  3. delete the vault folder (the folder where the masterkey file is stored) from your local machine
  4. download the vault folder from your online storage (for example via browser or ftp or whatever is available besides sync) and store in the exact same place where the „old“ vault files were stored.
  5. open the vault and check if problem is solved
  6. enable sync again.

Or you can try to find the encrypted files to the affected unwanted files and try to delete them manually (which should cause the same problem, but you never know)

  1. download the online stored vault to your local machine (again, via browser, etc. not sync)
  2. use a tool of your choice to compare the encrypted vault files from your original vault with the one you have downloaded and find out which files are in your original vault that aren’t in the one you have downloaded
  3. if you have found some, try to delete these files manually. (Vault should be locked)