Cannot delete files containing ; or % in their names

Hi all,
I’m new to cryptomator and coming from a mix of truecrypt and 7-zip with encryption für my cloud storage. So I’m pretty excited about cryptomator, which seems to make things a lot more comfortable (as far as I can see by now).

Unfortunately I have trouble with one file that cannot be deleted from vault and kindly ask for your suggestions how to solve this.

System: Windows 10
Cryptomator Version 1.3.1:
Filename: aaa_bbbb_ccccccccccccc_ddddddddd%5B1%5D_ger.pdf (I name this because my suggestion is that here may be the problem.)

I had this file on my System and was able to copy it to the vault. Later on I decided that this file is obsolete and wanted to delete it.
Error Messages File Explorer:
If I try to delete the complete folder: none.
If I try to delete the single file: none.
If I try to rename the file: “File was not found”.

What I have done to solve this:
First I though is is an indication error. So I did what everyone would do: close the vault and reopen it. Did not solve the issue.
I restarted the System: no result.
I tried to delete from command line: no result (file not found)

So I guess either the file was deleted, but cryptomator does still show it, or it was not delete but cannot be found anymore.

I’m thankful for any help.
Kind Regards

I think there are certain problems with percent escapes and the Windows WebDAV-Client, as reported on GitHub.

A current workaround is to use e.g. Cyberduck to either connect to the unlocked vault or directly access the vault, if it is stored in the cloud.

In the long term we try to move away from WebDAV to avoid such problems. But this will still take a while.


thanks for the quick reply.
Cyberduck solved the problem.



Have the same problem as Michael describes, just want add that I’m guessing it extends to more characters than percent [ % ]. I’m experiencing the same problems on a couple of files of mine that includes the
semicolon [ ; ] character.

Will try the above mentioned workaround.
Thanks for sharing.


This one has recently been fixed in our WebDAV implementation. It will be solved in Cryptomator 1.3.2.

Aaaah! Great!
Never figured out how use Cyberduck properly. Then time ran out and had to be spent on more pressing matters. Isn’t much of an issue for me anyways, just something… annoying.

Otherwise, thanks for a great app! Works very well with my soultion, Cryptomator/ service, on my three/four different machines.
Keep up the good work! Wich reminds me, must start donating soon…

1 Like