Attempt to open Cryptomator vault in DropBox reports "an error occurred"

On a Samsung Galaxy S6 running Android 7 with latest version of Dropbox app (86.2.2). Cryptomator version is 1.3.0.

When I attempted to view the files in my vault, I get the generic error message “an error occurred”. No files are listed.

I first tried to delete the vault and add it again but I get the same error upon typing in the vault unlock passphrase. I then removed the app, installed the app again, added the vault but there was no change when after typing in the passphrase. I just get that unhelpful error message.

Any ideas why? The desktop Cryptomator app has no problems accessing the vault.

Please let me know where I can send the “log.zip” file for further review.

Thanks in advance!

Thanks for your feedback!
Please use this tutorial: How do I enable debug mode on Android?

Would be awesome to have a look into your log file!

Thanks for the response.

Where should I send the log.zip file for further review?

If you press “Send log file” in the settings, your mail app should be opened with a new mail and all necessary flags set (like the mail address: support@cryptomator.org).

I have sent the log.zip as requested. It will be coming from my GMail account (joe.kang@gmail.com).

I should note that in trying to get the error to happen again, Cryptomator has “magically” been able to access my vault. I am no longer seeing the “an error occurred” message.

I am going to restart my phone to see if the problem has truly gone away or not.

I hope you’re able to see something in the debug log that I have sent.

Thank you very much and yes, we found something:
java.lang.IllegalArgumentException: com.google.b.b.a$d: Unrecognized character: c

All encrypted files are stored Base32 encoded. We don’t know why but the API from Dropbox (which we use to access their cloud) are retrieving a very small amount of files with lowercase characters even when they should be case insensitive what is with the sync clients verifiable and which are created with uppercase characters: https://www.dropbox.com/developers/documentation/http/documentation

Case insensitivity
Like Dropbox itself, the Dropbox API is case-insensitive, meaning that /A/B/c.txt is the same file as /a/b/C.txt and is the same file as /a/B/c.txt.

This is a bug in the Dropbox API, we will create an issue in their repository for this problem

1 Like

Interesting! Thanks for the update!