An unexpected error occurred 1.5.13

Hi,
unfortunately I could no longer open my safe.
Then I tried to import the backup file. Unfortunately I got the following error. But I still have the actual vault file.
What should I do now?
Can I still save my data?

java.nio.file.FileSystemAlreadyExistsException
at org.cryptomator.cryptofs.CryptoFileSystems.lambda$create$0(CryptoFileSystems.java:49)
at java.base/java.util.concurrent.ConcurrentHashMap.compute(Unknown Source)
at org.cryptomator.cryptofs.CryptoFileSystems.create(CryptoFileSystems.java:40)
at org.cryptomator.cryptofs.CryptoFileSystemProvider.newFileSystem(CryptoFileSystemProvider.java:301)
at org.cryptomator.cryptofs.CryptoFileSystemProvider.newFileSystem(CryptoFileSystemProvider.java:93)
at java.base/java.nio.file.FileSystems.newFileSystem(Unknown Source)
at java.base/java.nio.file.FileSystems.newFileSystem(Unknown Source)
at org.cryptomator.cryptofs.CryptoFileSystemProvider.newFileSystem(CryptoFileSystemProvider.java:134)
at org.cryptomator.common.vaults.Vault.createCryptoFileSystem(Vault.java:121)
at org.cryptomator.common.vaults.Vault.unlock(Vault.java:138)
at org.cryptomator.ui.unlock.UnlockWorkflow.attemptUnlock(UnlockWorkflow.java:107)
at org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:90)
at org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:44)
at javafx.concurrent.Task$TaskCallable.call(Task.java:1425)
at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.base/java.lang.Thread.run(Unknown Source)

java.nio.file.FileSystemAlreadyExistsException can only occur when an attempt is made to unlock the same vault a second time within the same session.

Please fully quit and restart Cryptomator. What happens on your first unlock attempt?

Hi, Cryptomator is not open on any device. I installed 1.5.13 on the desktop. I go to the vault file. No backup file.
I enter the password and also get the message that it has been unlocked and that I can access the files.
A window opens and I only see one PDF document. Usually I still see 2 folders, each containing files.
But the content itself is still there, I can see that in Windows Explorer, but encrypted.
I would be very happy if you can help me.

To be honest, I have difficulties following what you did here exactly. How exactly did you (or didn’t you?) restore a backup? Did you restore any previous revision of the d directory or did you replace just the masterkey file?

From what you describe, it might be possible you’re using two different keys here.

Hello,
Thanks for helping me!
At first I used the program as normal. I hadn’t adjusted anything. It was opened. I did not see anything.
But there is a backup file from December. Then I tried those as I thought the main file was corrupted. But the backup file does not work either.
Now I’ve undone it.

Do you speak in German?

© 2021 Skymatic GmbH • Privacy PolicyImpressum