All Files Missing after Upgrading vault

I upgraded my vault without any error Messages. All Files where local.
When I open my vault it’s completely empty. The encrypted Files are still there. But Cryptomator isn’t showing them.

I tried installing the older version again but that is showing me now that the Password is wrong and that is definitely not the case.
What can I do to fix this?

You can not go back to an earlier version of cryptomator after upgrading to 1.5 It changes the structure of your encrypted vault, which 1.4 can not understand.

What operating system are you running and cryptomator version did you use to upgrade?
Do you know what file system type your cryptomator vault is on? (eg NTFS, FAT, EXT4)

Im Using Windows 10 with Cryptomator 1.5.4
My vault is in a NTFS file System.

I also reinstalled the Dokan library but that didn’t help. The logs aren’t showing any errors.

I would recommend a “clean” install of cryptomator and dokan , especially since you tried downgrading to 1.4. Dokan requires reboots to fully remove /enable it, so i’d suggest the following.

Uninstall cryptomator
Uninstall dokan driver
Reboot system
Install the latest cryptomator 1.5 with the included dokan driver
reboot again before using.

Check the cryptomator options is set for dokan (not webdav)
try unlocking your vault.

Hopefully this will sort it, but If its still empty a debug log might help.

I did all of that. Uninstall Cryptomator and Dokan --> Reboot --> Installed Cryptomator 1.5.4 with Dokan --> Reboot.

Its still not showing anything.

This is the Log:
https://pastebin.com/Dpz7Pm0q

I managed to solve it.
I looks like the masterkey file wasn’t upgraded correctly.
After restoring the old Masterkey that was used before the Upgrade I could open it correctly.
Thanks for the help anyways.

1 Like
© 2020 Skymatic GmbH • Privacy PolicyImpressum