Add existing vault dialog does "nothing"

Now I can’t add the vaults that were not migrated to format 7. When I go to choose the file masterkey.cryptomator using the dialog box, after I select it, the same dialog box window appears.

Could it be that 1.5 cannot display vaults in different formats?

It can’t unlock them but it will show them in your vault list and ask you to migrate them if you try to access them.

I can’t add them to 1.5. This is what I see in the log when I try to add a vault in the previous format:

21:26:56.656 [main] INFO  org.cryptomator.launcher.Cryptomator - Starting Cryptomator 1.5.0 on Mac OS X 10.15.4 (x86_64)
21:26:56.658 [main] DEBUG org.cryptomator.logging.DebugMode - Debug mode enabled
21:26:56.658 [main] DEBUG org.cryptomator.launcher.IpcFactory - [Client] Failed to connect.
21:26:56.700 [main] DEBUG org.cryptomator.launcher.IpcFactory - [Server] Wrote IPC port 50371 to /Users/xxx/Library/Application Support/Cryptomator/ipcPort.bin
21:26:56.701 [main] DEBUG o.c.launcher.IpcProtocolImpl - Received launch args: 
21:26:56.702 [main] DEBUG org.cryptomator.launcher.Cryptomator - Did not find running application instance. Launching GUI...
21:26:56.795 [main] DEBUG o.c.ui.traymenu.TrayIconController - initialized tray icon
21:26:56.819 [main] DEBUG org.cryptomator.common.CommonsModule - Starting App Background Thread 001
21:26:56.820 [App Background Thread 001] DEBUG o.c.ui.launcher.FxApplicationStarter - Starting JavaFX runtime...
21:26:56.824 [main] DEBUG org.cryptomator.common.CommonsModule - Starting App Background Thread 002
21:26:56.918 [JavaFX Application Thread] INFO  o.c.ui.launcher.FxApplicationStarter - JavaFX Runtime started.
21:26:57.022 [JavaFX Application Thread] TRACE o.cryptomator.ui.fxapp.FxApplication - FxApplication.start()
21:26:57.330 [JavaFX Application Thread] DEBUG org.cryptomator.ui.common.FontLoader - Loaded family: Font Awesome 5 Free Solid
21:26:57.395 [JavaFX Application Thread] DEBUG o.c.u.m.MainWindowTitleController - init MainWindowTitleController
21:26:57.605 [JavaFX Application Thread] DEBUG o.c.u.m.MainWindowController - init MainWindowController
21:26:57.876 [JavaFX Application Thread] DEBUG o.cryptomator.ui.fxapp.FxApplication - Showing MainWindow
21:27:02.494 [JavaFX Application Thread] DEBUG o.c.u.a.AddVaultWelcomeController - AddVaultWelcomeController.chooseExistingVault()

Relevant part of the log is missing, it should follow right behind this:

It ends there. The problem I have is that when I’m in the window to choose the vault, I choose it and nothing happens. Cryptomator just shows again the window to choose the vault.
Can you try adding an existing vault that is in the format of 1.4.17?

Just to be sure, you still can download 1.4.17 here:

Of course, you wouldn’t be able to open vaults in the new format but can you confirm that there aren’t any issues with the old version?

I tried a lot of variations now (also with macOS 10.15.4) and wasn’t able to reproduce the issue. Is there anything special about your setup?

  • Do you run macOS in a VM?
  • Do you have any third-party security software installed?
  • Is the affected vault located in a special location/directory?

Let me just write my journey. I had several vaults in 1.4.17 using Dropbox as the sync service. Some of the vaults were in my Dropbox folder in my computer, but some were not. I was using Dropbox’s selective sync to download the vaults that were not saved locally only when I needed them. Cryptomator would still display all the vaults in the main window, but when I selected those vaults, Cryptomator would display a warning asking whether I had moved them. I was fine with that behaviour, as I knew what was going on. Then I updated to 1.5. I converted the vaults that were local without problem and started to sync the vaults that were not local using selective sync in Dropbox. 1.5 would still display the vaults that were not local since I supposed it “inherited” that from 1.4. I disabled some options in 1.5, like automatic starting when the computer restarts. Then I closed 1.5. When the vaults finished syncing, I tried opening again 1.5 to convert the cloud vaults to format 7. That’s when 1.5 couldn’t open. However, when I deleted the settings.json I could use 1.5 again. However, I had to add all the vaults again. So the vaults that were already converted to format 7 were added, but the cloud vaults that were not converted could not be added. That’s my last post, that 1.5 just shows me back the window for adding the vaults (that were not converted) when I try to add them. I suppose a warning stating that the vaults are in the old format would be useful here.

I downloaded 1.4.17, and tried adding the cloud vaults (that were now saved locally) but now I get a warning saying that the vaults are in a newer format. So I’m lost now. It’s not a big deal, since I can roll back my Dropbox to the state it had before all this happened and use 1.5 to convert everything again.

You asked about VM, security software and location. I don’t use a VM to run macOS. I have some security software from Presumably their software ransomwhere? could be the one causing the problem? But with 1.4.17 I never had any issues. I also have installed ReiKey, DHS, WhatsYourSign, Do Not Disturb, TaskExplorer, Netiquette, KextViewr and KnockKnock from the same website.
Finally, about the special locations, like I mentioned before, I had some vaults not saved locally, that I would only sync using Dropbox’s selective sync when I needed to use them.

I just wanna say that this is not a complaint and you are really filling a void in the security market out there. I really like you product and will continue using it. Please let me know if I you need more information.


1.4.x not being able to deal with newer vault formats is expected behaviour. There should be no need to revert and upgrade again. If migration was successful, there is nothing a second migration would do differently.

Now back to the original problems:

1. Cryptomator not starting until you deleted the settings.json.

Absolutely no idea what happened here, this is the first time I hear about this. I suspect there were other factors affecting the launch, but we will probably never know.

Since you resolved this yourself, I don’t think we should investigate any further, unless anyone else can reproduce it.

2. Cryptomator stuck in the “add existing vault” dialog.

Just to make sure, we’re talking about the same dialog:

After choosing a file from the “macOS file chooser”:

You’re back at this dialog:

And while for your “local” vaults the dialog just closed and your vaults were added to your vault list, this dialog just does “nothing” for your fourth vault. Did I understand this correctly?

That is correct. I am back at the dialog of the last image.

And now you can reattempt opening it or cancel it? Or is the UI in any way frozen or otherwise impaired?

It’s not frozen. I can try to open it again and I keep getting the same result.

It seems to me that the masterkey file is somehow… weird. Could you please do the following:

  1. Create a folder (let’s call it “Test”) somewhere outside of Dropbox.
  2. Create a folder “d” inside “Test”.
  3. Copy the masterkey file (that doesn’t work) to the “Test” folder.

Now try to add this vault. In my case, I was able to add the vault and even unlock it (of course it’s empty then). But even if that doesn’t work, could you please open the masterkey file with a text editor and check its contents? It should look something like this:

  "scryptSalt": "...",
  "scryptCostParam": 32768,
  "scryptBlockSize": 8,
  "primaryMasterKey": "...",
  "hmacMasterKey": "...",
  "versionMac": "...",
  "version": 7

Or in your case, "version": 6 since it hasn’t been migrated yet.

That works. It’s telling me about upgrading the vault. Is it safe for me to post that file? I suppose I can change the password, so here it is:

  "scryptSalt": "Xxxxx+=vvbbb",
  "scryptCostParam": 32768,
  "scryptBlockSize": 8,
  "primaryMasterKey": "[54 Didgets]==",
  "hmacMasterKey": "[54 didgets]==",
  "versionMac": "[43 Didgets]=",
  "version": 6

PS: sorry for the late reply, I was prevented from posting so many replies in my first day.

I don’t have a good feeling of posting this in cleartext here, so I updated your post. Devs can see the original if my assumption that this information is not critical for the analysis is wrong.


It is “secure” (that’s why the masterkey file can be put in a public cloud, see: Why is the masterkey stored in the cloud?

However(!), I agree that it’s unnecessary to post the actual contents here because they don’t seem to add any value to finding the actual issue.

I still don’t understand why the masterkey file can be selected if it’s put in another location. Some vaults in Dropbox work, some don’t. Is there anything special about the vault’s name? Or are there special characters in the path leading up to the vault? :thinking:

1 Like

Nothing special about the location. In fact, one of the vaults that I successfully migrated had special characters in its path, not this one though. What do you mean by “some vaults in Dropbox work, some don’t”? is that a know issue or were you just restating the particularities of my problem?

I was just restating the particularities of your problem and trying to guess what might cause them.

@amrods Can you please attempt the following:

  1. In your /Applications folder, right click on and choose “show package contents”
  2. Within these package contents, navigate to Contents/Java
  3. Replace the file ui-1.5.0.jar with this one
  4. Start Cryptomator, enable debug logging, reattempt adding the vault

You can now deactivate debug logging again. Please attach the log contents (redact any paths, if you like).

I already upgraded tha data into version 7 but the issue is adding two vaults ( one Local data -> show OK ) and one mapped data via SMB3 Windows 10 ( drive mapped data via SMB3 share -> no show)

I am not able to open the shared data ( no show) if data is on shared drive.
This worked since i use Cryptomator ( started in 2017 )
Two vaults open works if data is on local drive or onedrive

My issue was a windows smb3 encrypted remote share.