Wrong password on certian devices and under certian conditions


Im having an issue where i create a long password and i get the triangle icon, but it still lets me proceed and create the vault. i can then use the exact same password to unlock the vault. but when i try to unlock the vault on android, it fails and tells me wrong password.

additionally, ive created a vault with a very short password i made on my iphone. on my macos i cant decrypt it unless i type the password instead of copy and paste. if i copy and paste part of the password or the password in two sections it works. i tried the same for the long password on my android, and it does not work.

struggling here and just bought the app for both android and IOS. Hopefully someone can help me resolve.

EDIT: Also, was just trying to decrypt the vault i made on IOS on my MacOS again and couldnt do it if the password was visible or by copy and paste. only if i type the password without it being visible, will it decrypt.

EDIT: when i copy and paste i get the triangle icon, but if i press delete once it goes through, but only if the password is not visible, if it is visible then it doesnt work.

EDIT: What i can see is its most likely some copy and paste issue. Trying to narrow it down.

EDIT: What I’ve been able to narrow down is that it is MacOS issue with copy and paste. I created a vault on MacOS but only by typing in the password. then i tried on my android with success copy and pasting. if i copy and paste from MacOS i have to press the delete key once and then it goes through. This is a pain in the ass because i prefer to use long passwords and will need to type them in if i want to create them and get a backup phrase. is this a known issue on MacOS?