Windows is constantly unmounting my Cryptomator Drive

So my Cryptomator drive keeps becoming “corrupted” as windows unmounts the drive it is assigning to my vault. I manage to unlock my vault successfully, then cryptomator will assign a drive to it or I set one manually and after a few minutes this is what the pop-up reads when i try to access the drive:

LOCATION NOT AVAILABLE

“X:\ IS UNAVAILABLE. IF THE LOCATION IS ON THIS PC, MAKE SURE THAT THE DEVICE OR DRIVE IS CONNECTED OR THE DISC IS INSERTED BLAH BLAH BLAH”.

Only way to solve this is to LOCK the vault and UNLOCK IT again, giving it a new different drive letter from the “corrupted” one if Cryptomator doesn’t do this on its own. After a few minutes the drive will corrupt itself again.

Pleas HELP this is driving me insane.

I have tried reinstalling Cryptomator several times now, as well as the Dokan Library; and have tried creating an entirely new vault but the problem persists, even on new vaults.

I have had this issue for some weeks now, was hoping for a patch to fix it but after this last update failed to do so I am thinking there is an issue on my end.

Thank you.

I have the same problem since today! Only difference is that I it even happens when I specifying the vault letter! I have no idea what to do I reinstalled cryptomator again but it keeps happening. Please if you figure it out please reply. The update 1.5.10 maybe? :confused:

Edit1: I de-installed 1.5.10 and tried the portable cryptomator and had the same problem.Tthen I installed the 1.5.9 and again the same problem. I don’t get problems with vaults on veracrypt so I guess is the cryptomator problem

Edit2: I tried opening a vault from a backup I made and knew it worked and happened the same thing. so it is not a corruption of my files it is the cryptomator software interaction with the windows PC

Edit3: I tried opening the same vault from my back up with another windows 10 PC and they worked just fine. so I guess it is a problem from windows I guess, the thing is how to fix it.

I guess it’s caused by dokany. Please switch to WebDAV to see if the problem still occurs. Please have a look in the Cryptomator logfile. Anything in there that might be a hint?
If you use dokany, please check if the latest version is installed.

Yes I can confirm the issue is with DOKANY, since I cannot reproduce it with WEBDAV.

Now that you mention it, I think the problem began around the time when CRYPTOMATOR forced the dokan lubrary latest version 1.4 on my system.

Thank you.

Ok so the problem is caused by Dokany, how do we fix it? I deinstalled and reinstalled and did not help. what I manage to do is make it sort of work (I can’t manage to make vlc work within the vault as before) after closing an app on the task manager RAPS.exe (don’t know why). But more importantly how to fix dokany?

you will have to switch to WEBDAV.

mind you, its still not as stable as it once was because i still experience an issue that CRYPTOMATOR does not unlock the vault when set to automatic unlock upon launch. (it does not show on file explorer).

so i need to manually launch cryptomator and unlock the vault for it to show.

so far though, with WEBDAV, once it is manually unlocked it has not corrupted itself.

as stated above, these issues began not with the most recent patch but with the one prior, the one that forced the latest dokany library.

or maybe it was windows update to 20H2…

Yeah I know I can use Webnav. Although after uninstalling smartbytes it worked except opening videos with VLC. But I don’t like something not working. But I guess we need to wait so hopefully the next dokey update fix that, or just wipe the PC and install windows from scratch.

For the record; I have the same problem with version 1.5.6 on a Windows 10 pc. The vault is stored in Onedrive with Onedrive’s local folder on an SD card. I will give WEBDAV a try.

I’m having the same issue after updating to 1.5.10 (Dokan 1.4.0100). I tried uninstalling both Cryptomator & Dokan, reverting both to older versions and they all have the same issue now. There must be something about Dokan 1.4.0.0100 that screwed this up. Super strange that even after completely uninstalling it and trying an older version that it’s still broken.

WebDAV does work, but it isn’t a viable solution for me since I have files over 4GB and I now can’t access them or copy them.

Desperate for any help on this.

Use Task Scheduler on Win 10 to delay startup of the application for one minute after login. Worked for me.

That hasn’t worked for me :frowning:

You did disable autostart in Cryptomator, right?

Yep I did. I tried changing the mounting drive letter to something different and it seems more stable now so fingers crossed.

Now that’s interesting. Out of habit, I always label my Cryptomator volume as T:…

When you look into the log files, do they contain the message WARN o.c.frontend.dokany.MountFactory - Mounting timed out ?

I can check, where is the log file located on Windows?

Edit: Never mind, found it and yes, I do see Mounting timed out when I was trying to mount as Z:. Mounting as N: has been working fine.

We found possible reasons for this, more information can be found in the ticket on our issue tracker:

There are also workarounds proposed.

Dokany released a new version today: https://github.com/dokan-dev/dokany/releases/tag/v1.4.1.1000, which includes fixes for the issues mentioned in the linked bug ticket. Since we still cannot reproduce this issue, we need people testing and reporting back.

In order to use th new lib, the one shipped with Cryptomatr (C:\Program Files\Cryptomator\dokan1.dll) must be renamed.

© 2021 Skymatic GmbH • Privacy PolicyImpressum