Win10/64 21H1 Enterprise: v1.6.0-RC3 fails to install

Hello!
Even from a command line under the administrator’s account the msiexec /a cryptomator-1.6.0.-rc3.msi does not install the program.
A frame with the unpacking progress bar appears for a moment and then - closes without any comments.

Why is that?

Is there somewhere an *.exe version of the installer?

Is an 1.5.x version of Cryptomator already installed?

No, this is on a clean OS.

Did you tried using the standard msiexec installation flag /i?

What i gather from the this stackoverflow post that you don’t really install the app with it. And currently we only support a normal installation.

Edit: i take that back, it might work. But you need to specify also the targetDir when using the administrative install and it should not be the same as the extracting msi, see installation - Error 2203 while extracting msi - Stack Overflow and wix - What is the purpose of administrative installation initiated using msiexec /a? - Stack Overflow.

Sure I tried the standard way (double-clicking on the MSI-file), - it failed.
Only seeing it fail - I begun those additional efforts.
No matter what - I cannot install v1.6.0-rc3 as MSI.

I wish it was a plain EXE installer…

You can help us by logging the installation process:

misexec /i Cryptomator-1.6.0-rc3.msi /l*vx installLog.txt

It creates in the current working dir the file installLog.txt, which you need to upload. If you have privacy concerns, send me the log file via a PM.

:frowning: Looks like I’m too “young” to PM anyone.
The log is ~830kB, I zipped it here.

Hope it sheds a light on the problem I have.

I looked into the log, line 2955 is insightful:

MSI (c) (DC:4C) [16:19:11:631]: Product: Cryptomator -- Installation completed successfully.

What makes you think that the installation was not successful? :thinking:

Yes, I must admit - I did not even dare to look into this log.

I thought it failed because v1.6.0-rc3 install process did not look like v1.5.17 installs, - no license acceptance, no anything.

Now, seeing that to use Cryptomator v1.5.17 I must dismantle all my defences (to disable SRP, to log-in as an admin), I tried to do so with v1.6.0-rc3, and it actually installed.
However, it did not appear under the letter C, it got itself into the letter U - as an “Unknown” program.
Starting it with administrative rights I could create a vault at https://wd.mfd.sk, unlock it, reveal its’ drive - and store a file there.
Looks like v1.6.0-rc3 works - for administrators it is.

I’ll ask here - will it work for a LUA as well? Will it be compatible with a well-disciplined OS?
I mean - both LUA and SRP are essential for me.

This should not be the case, we just noticed now that the installer build wrong without throwing an error. We’ll release soon an updated windows installer.

© 2021 Skymatic GmbH • Privacy PolicyImpressum