[Win 10] One issue discovered with 1.4.15 [Updated]

[Update: Ignore report of problem with Cryptomator not minimizing. System restart fixed that problem]

When I upgraded to 1.4.15, I removed 1.4.13 through Settings -> Apps (the “new” way in Windows). Today, I noticed in the old Control Panel -> Programs and Features application that both 1.4.13 and 1.4.15 were listed as being installed.

When I clicked “uninstall” for 1.4.13, it removed the directory, etc. for 1.4.15. But, the entry in the old “Programs and Features” for 1.4.15 remained. I know that my 1.4.15 installation was removed because it no longer appeared in the Start menu list of installed applications.

To get to a “clean” state, I selected the 1.4.15 entry in the old Programs and Features control panel item and clicked uninstall. It removed whatever remained of that entry.

I installed 1.4.15 again and Cryptomator was behaving as though it was installed for the first time. My existing vault did not show up in the list and when I added it, I had to select the various options and drive letter assignment again. That all worked as expected.

Now, however, when I click the “X” button to close the window. Instead of minimizing to the notification tray and closing the window, Cryptomator complains that it can’t exit the application because vaults are still open. If I don’t want to see the window, I can only minimize it to the taskbar.

Why is it behaving like this now? Before I “cleaned” up my Cryptomator installation, I was able to click the close window “X” button and the window would close but Cryptomator’s task tray icon would remain.

Thanks in advance!

I removed 1.4.15 again and tried forcing it to install as Administrator as a test. It still behaves the same way. It tries to exit the program instead of minimizing to the notification tray.

As I updated my original post, ignore the minimizing problem. Windows restart fixed that issue.

So regarding the other problem with two installations listed under “Apps and Features”: This is indeed a known issue. Will not happen again with future versions.

We had to change the unique identifier of the installation. We could have done it sooner or later, but decided to no longer defer it as the number of affected users will only increase over time.

That said, the deinstallation should (in theory :wink:) not have deleted your app settings.

Edit: Damn, there is actually a line of code instructing the uninstaller to delete the settings. Sorry about this. I opened an issue on GitHub to discuss whether we want to change it in future versions.

Thanks for the reply. Glad to know that the problem with settings being deleted will be addressed in future release.

I’m also glad to know that there’s a good reason for why the application appeared twice in Apps and Features.

If anyone else stumbles upon this, here is a

Workaround for removing the old installation entry:

  1. Backup your app settings by making a copy of %appdata%/Cryptomator (e.g. temporarily store it on your desktop)
  2. Uninstall all Cryptomator entries from Programs and Features
  3. Reinstall the latest Cryptomator version
  4. Restore your %appdata%/Cryptomator directory

Beginning with Cryptomator 1.4.15, all newer versions will use the same installation IDs and therefore you will only see one entry.