Why is the known issue on Mac not fixed? Lock vault / Spinning wheel

There are several threads already regarding the inability to lock vaults on Mac (especially M1 and M2), yet this issue still persists.

I can’t lock the vault.
Cryptomator won’t stop running. Even after force quitting there seem to be open processes that prevent the Mac to restart or shutdown. I have to force shutdown.
Restarting Cryptomator results in the app no longer opening (only after force shutdown of Mac).

Overall the experienc is very bad and the program unusable in its current state. Should I use the Intel version with Rosetta? Does anyone have experience with that version? All I can say is the Apple Silicon version does not work and should not even be offered on the website.

It’s open but there is no process in activity monitor. Unable to quit…

We finally have a solution for this but we’re still conservative about it. Read more about the reasoning here: https://cryptomator.org/blog/2023/02/01/1-7-0-what-you-need-to-know/#experimental-support-for-fuse-t

I tried to use FUSE-T but when I open my vault no files are displayed. I tried to do an ls through the terminal in my vault’s folder and I get this error: Permission denied (os error 13). I checked and the vault’s folder is owned by the user I’m currently using, so I don’t know what is happening.

Do you have any idea about what’s causing this issue?

What you are saying is you have no Mac support anymore.

Fuse-T doesn’t come with Cryptomator. Do you really expect the average user to

  1. search the internet for a solution
  2. install homebrew
  3. install a small non-open-source project from an unknown third-party dev

Apple Silicon isn’t going away. That’s what Mac is now. So I find it a bit odd that you won’t put more effort into this issue.

  1. It’s linked right at the download page. No searching required.

  2. Installing homebrew is not required…that an optional way to install FUSE-T.

  3. I believe this is valid criticism. I understand FUSE-T is partly open source and partly closed. Not exactly sure what parts Cryptomator uses. A project that advertises itself as better security because of open source shouldn’t rely on closed source third-party code. That said, FUSE-T has been working great for me on my M2 pro. My experience is it is working well on Apple silicon using FUSE-T or macFUSE. FUSE-T seems to provide better native integration with Finder etc.

1 Like