Version 1.5.4 does not open

I installed version 1.5.4 on Windows 10. It only starts minimized and I cannot open it. After
a reboot, once in a hundred times the program window appears but then I cannot open my vault. After clicking on the file, nothing happens, apart from a non active window opening up saying, my vault needed to be converted / updated. If i close the “open existing vault” dialogue, this window stays open but I cannot convert / update my vault. Absolutely strange behaviour. Version 1.4.15 works just fine!!!

Any help?

Hello to Cryptomator Community :slight_smile:

this sounds like a problem in the GUI. But before jumping to any conclusion, i’d like to state the following: With Cryptomator 1.5.0 we introduced a new vault format leading to the need of migrating older vaults. Therefore, before you can unlock the old vaults, you need to migrate them.

If you are aware of that and the UI is not responding, you can try out this workaround from our issue tracker and report back.

Thank you for the quick response. Performed a clean install of version 1.5.4 and now the gui opens up, but when I try to load the old vault (which is on a nas network drive), the “open existing vault” window stays in front and the window for migrating the vailt opens in the background, so I cannot click on it to migrate the vault. Any suggestion what I can do?

The “Open Existing Vault” window is modal, meaning that it blocks the main window as long as its open. It should close after you successfully selected the masterkey file for a vault. You can also add a vault to Cryptomator by double clicking on the masterkey.cryptomator file. For more info how to use Cryptomator, look at our docs.

That said, this is how it should work. If the “Open Existing Vault” window does not close after successfully selecting a masterkey file, it is an error. Then you should try the workaround.

I tried the workaround to no avail. cryptomator is back to only opening as a tray icon. The one time this morning, the program window opened up, obviously was that “one in a million - chance”.

I did some more testing and found out, the program only starts to the gui if I delete all files in the “users / appdata / roaming / cryptomator” folder and reboot Windows. But it is not able to open the vault and attach a drive letter. I think I’ll fall back to version 1.4.15 for now or are there any significant disadvantages apart from the new optics and the new vault format?

Please keep in mind that the vault version from 1.5.x (Version 7) is not compatible with vault version from 1.4.x (Version 6)
If you want to downgrade you’ll have to create a new vault or restore a backup.

Thank you so far! Cryptomator 1.5.4 is now running, but if I unlock the vault, in the next step I cannot attach a drive letter (no matter whether I use dokany or webdav) and Windows shows an error message. When I boot up in safe-mode, it works fine, so there seems to be some software/driver conflict. Any advice how I can narrow this down? Thanks again! Michael

What error messag? What drive type (Dokany/WebDAV)

If dokany, I would try a reinstall if it.
Please make sure to reboot your system after uninstalling dokany and after reinstalling dokany. Some users reported that not rebooting caused issues for them.

Thanks once more! In the end, a clean install of Windows solved the problem, whatever it was.

The solution to nearly all of our windows problems. :rofl:

© 2020 Skymatic GmbH • Privacy PolicyImpressum