Vault unlocks and assigns drive letter, but later the drive cannot be opened

Your dokany version is outdated.
Please update your dokany installation to the latest one.


If this does not solve the issue, does the mounting timeout also occur if you switch the vault volume type to WebDAV?

Thanks for the link. I installed the latest release1.4.0.1000 via DokanSetup_redist.exe and restarted my computer for good measure. Still having the mounting error though but noticed the version didn’t update in the logs?

13:33:41.994 [JavaFX Application Thread] WARN  o.c.keychain.KeychainManager - LOAD
13:33:41.994 [JavaFX Application Thread] DEBUG o.c.k.WindowsProtectedKeychainAccess - Attempting to load keychain from C:\Users\...\AppData\Roaming\Cryptomator\keychain.json
13:33:42.588 [JavaFX Application Thread] DEBUG org.cryptomator.common.CommonsModule - Starting App Background Thread 004
13:33:42.588 [JavaFX Application Thread] DEBUG o.cryptomator.ui.fxapp.FxApplication - Showing UnlockWindow for Testing
13:33:42.589 [JavaFX Application Thread] DEBUG o.c.common.vaults.VaultStats - stop recording stats
13:33:42.591 [JavaFX Application Thread] DEBUG o.c.ui.launcher.AppLifecycleListener - Allow quitting without prompt: false
13:33:42.617 [App Background Thread 004] DEBUG o.cryptomator.cryptofs.ReadonlyFlag - Vault opened for read and write.
13:33:43.066 [App Background Thread 004] INFO - Dokany version: 130
13:33:43.066 [App Background Thread 004] INFO - Dokany driver version: 400
13:33:43.067 [App Background Thread 004] DEBUG o.c.frontend.dokany.MountFactory - Mounting on D:\: ...
13:33:43.067 [App Background Thread 004] DEBUG org.cryptomator.common.CommonsModule - Starting App Background Thread 005
13:33:46.069 [App Background Thread 004] TRACE o.cryptomator.frontend.dokany.Mount - Mounting still in progress.
13:33:51.071 [App Background Thread 004] WARN  o.c.frontend.dokany.MountFactory - Mounting timed out.
13:33:51.071 [App Background Thread 004] INFO  o.c.ui.unlock.UnlockWorkflow - Unlock of 'Testing' succeeded.
13:33:51.078 [App Background Thread 004] WARN  o.c.keychain.KeychainManager - 
13:33:51.079 [App Background Thread 004] DEBUG org.cryptomator.common.CommonsModule - Starting App Background Thread 006

However after updating, it seems same problem with WebDAV has been fixed. Will observe…

In relation to my previous reply - I looked into uninstalling dokany and reinstalling it again as I suspect it did not install/update properly.

It seems I have a problem in uninstalling it completely/cleanly in that I cannot seem to delete the dokan1.sys file that it generates (referred to this thread also). I was able the dokan1.dll file though.

However unlike the last user who posted there, I already did a registry clean up, made sure I had the right permissions, tried using Unlocker/LockHunter programs (could not delete, even at restart), booted in safe mode to try and delete it there, tried deleting via CMD…I can’t delete it! I don’t know what to do.

Getting quite frustrated now as I feel like this has to do with my cryptomator problems

In general, dokan1.sys is removed from the system if you uninstall Dokany and perform a reboot. The other way is to use the troubelshooting dialogue and load a seperate, slim Windows from where you can change files in your normal windows:

  1. Ensure that Dokany is uninstalled and you already tried the reboot solution
  2. Open the troubelshoot dialogue by entering the power menu, hold the key Left Shift down and click on Restart
  3. From there click “Troubleshoot”, “Advanced Options” and finally “Command Prompt”
  4. You may have to authenticate yourself, but after a reboot a Windows command prompt opens
  5. Now you need to delete the driver file. But you may need to try out different drive letters, because your actual Windows does not need to be mounted on C and you may hit the drive letter where the currently running, slim Windows is mounted. Hence, for the letters A to Z try out the following command where [$] needs to be replaced with a drive letter:
del [$]:\Windows\System32\drivers\dokan1.sys`

I advise against such clean ups, see here.

Okay, if everythings sober on the system again, there is currently only one thing I can say: You are not the only one, see e.g. Autostart working but mounting of drives fails (without an error message). According to your log files, the vault is mounted. But maybe not correctly integrated into the system. You can try to remove the the flag CURRENT_SESSION and see if this changes something, but be aware of the its implications:
Cryptomator on Windows: Accessing your vault with admin priviliges

Found a way to delete the file and reinstall Dokany before installing Cryptomator. Alas, even removing “CURRENT_SESSION” doesn’t seem to work for me. Just thought I’d give it a shot since this guy got it to work by uninstalling and reinstalling. In any case, hope a fix or workaround comes out soon.

I habe the same problem. The app opens and I unlock the fault. It assigns a drive letter. I can open Windows Explorer and see t he drive and its contents.
After 2-3 minutes the drive is there but is “inaccessible”. What is the best fix for the problem now? Update Dokany or to use WebDAV?

Not an option for me unfortunately as WebDAV does not work reliably. MS Word and Excel keep crashing when I work on a file that is stored in a vault.

Same problem here. Version 1.5.6, 64 bit, Windows 10, Dokany.

Uninstalled and reinstalled Cryptomator and Dokany several times, rebooting after each step. Deleted dokan1.dll from Windows\system32 and from Progams\Cryptomator. Also updated Dokay and made sure that correct versions showed up in the log file for Dokany (140) and Dokany driver (400). Also tried using the CURRENT_SESSION flag.

Still the same behaviour. After reboot Cryptomator starts and volume is mounted and accessible, but after 1-2 minutes it is gone. This also happens while copying or having files opened.

Now gone back to version 1.4.12. This was the last version without automount problems, at least for me. Troubles started with 1.4.15 latest, as far as I can tell.

Sorry for my english, I’m not a native speaker. It’s also my first post, so comments on what to improve are welcome.

I am having the same problem also. Vault is opened and I can assess the files as they are listed in Explorer. However, if I try to go and open another vault, Cyrptomator is hidden out of view and it will not come up so you can enter the credentials to open another vault. And since Cryptomator will not come into focus you cannot access the window to lock the opened vault.

However, I am on V1.4.15 as well waiting for the bugs to be worked out on the current version. I hesitate to upgrade but if this issue is not in the current version possibly that is where I need to go.
I run Win 10.

I experienced the same problem. Deactivate the virus software did not change anything. I updated dokan software which made things worse, the program reported about a keychain problem. I removed cryptomator and installed it again, now the keychain problem disappeared. However, the same problem: neither the assigned drive nor the webdav folder could be accessed.
No indication of a problem in the log file.
I installed a new subfolder in my documents folder and choosed that as a fixed path for cryptomator. That worked out well.
(system win 10-64 home, version 2004 (the latest))

A new subfolder within an existing encrypted folder? Or a new encrypted folder?

Not sure I understand your question. My encrypted folder is in a cloudstorage. I created a not encrypted subfolder in my documents section. I used the third option in cryptomator “choose your own path” (in the german version) and saved the path there. After opening the “Tresor” (not sure how it is named in the english version) the encrypted folder is mapped into this one (the files are seen decrypted). Is that what you wanted to know?

Vielen Dank für die Erläuterung. Jetzt verstehe ich, was Du gemacht hast. Ich habe bei mir nur keine dritte Option. Wo findest Du die? Beim geschlossenen Tresor kann ich als “Einhängepunkt” nur zwischen “Automatisch” und “zugewiesenen Laufwerksbuchstaben” wählen. Einen Pfad kann ich nicht angeben.

Thank you very much for the explanation. Now I understand what you’ve done. I just don’t have a third option with me. Where do you find them? When the vault is closed, the only “mount point” I can choose is between “automatic” and “assigned drive letter”. I can’t specify a path.

In der neuen cryptomator Version 1.5.6 (also die aktuelle) steht unter “entsperren” “Tresoroptionen”.
Unter “Laufwerksoptionen” steht ganz unten unter “Einhaengepunkt” “Pfad selbst waehlen”. Dort habe ich den Pfad eingetragen.

Fuer mich sieht das Problem nach einem Problem mit Zugriffsrechten aus.

Sehr interessant - leider habe ich diese Option bei mir nicht. Am Ende nach Z: habe ich keine Möglichkeit, einen Pfad einzugeben.

Very interesting - unfortunately I do not have this option with me. At the end after Z: I have no possibility to enter a path.

Just wanted to report that it seems the latest update (1.5.7) fixed my problems, can use the Dokany vault and it mounts/remounts with no errors now.

Unfortunately, the issue still persists for me with 1.5.7 and the updated Dokany.

Same for me!
The problem that occurred in version 1.5.6 still exists in version 1.5.7.
After opening the vault, the drive cannot be accessed a few minutes later (latest Dokany version is installed). You can avoid this problem by specifying a fixed path.

1 Like

Same here. :frowning:
Updated Dokany and Cryptomator, drive letter is assigned but vault is not accessible (from minute 1 as far as I can tell).
Only solution that works for me at the moment: unlock the vault manually. A fixed path does not work for me, I need drive letters assigned to the vaults.

Nevermind, I spoke too soon. Cryptomator was working fine, just restarted my computer and now it’s back to not working again - looks like the drive times out even while I have the folder open and viewing the files - then I just get the popup ex. “c:/ not accessible”