Vault needs to upgrade but fails

Hi there! I’m running into an issue opening my vault and looking for help.

When I select my vault, I get a message saying “Your vault needs to be upgraded to a new format, before you can access it” with a button to upgrade vault. I click the button and then I see this error:

Error TB89:N6FM:N6FM

My specs:
MacBook Air running MacBook macOS Monterey version 12.0.1
Cryptomator running version 1.6.3

Welcome to the Cryptomator Community :slightly_smiling_face: ,

did you already looked up the error code in our error database?

If not, I suggest you to do that first. If it is not present in the database, can you provide the error details from the box?

Hi there! I did not find anything there. Here is the text:

Error Code TB89:N6FM:N6FM
java.nio.file.NoSuchFileException: /Volumes/GoogleDrive/My Drive/<<Name of my drive>>
	at java.base/sun.nio.fs.UnixException.translateToIOException(Unknown Source)
	at java.base/sun.nio.fs.UnixException.rethrowAsIOException(Unknown Source)
	at java.base/sun.nio.fs.UnixException.rethrowAsIOException(Unknown Source)
	at java.base/sun.nio.fs.UnixCopyFile.move(Unknown Source)
	at java.base/sun.nio.fs.UnixFileSystemProvider.move(Unknown Source)
	at java.base/java.nio.file.Files.move(Unknown Source)
	at org.cryptomator.cryptofs@2.1.1/org.cryptomator.cryptofs.migration.v7.FilePathMigration.migrate(
	at org.cryptomator.cryptofs@2.1.1/org.cryptomator.cryptofs.migration.v7.MigratingVisitor.postVisitDirectory(
	at org.cryptomator.cryptofs@2.1.1/org.cryptomator.cryptofs.migration.v7.MigratingVisitor.postVisitDirectory(
	at java.base/java.nio.file.Files.walkFileTree(Unknown Source)
	at org.cryptomator.cryptofs@2.1.1/org.cryptomator.cryptofs.migration.v7.Version7Migrator.migrateFileNames(
	at org.cryptomator.cryptofs@2.1.1/org.cryptomator.cryptofs.migration.v7.Version7Migrator.migrate(
	at org.cryptomator.cryptofs@2.1.1/org.cryptomator.cryptofs.migration.Migrators.migrate(
	at org.cryptomator.desktop@1.6.3/org.cryptomator.ui.migration.MigrationRunController.lambda$migrate$3(
	at org.cryptomator.desktop@1.6.3/org.cryptomator.ui.common.Tasks$
	at java.base/ Source)
	at java.base/java.util.concurrent.Executors$ Source)
	at java.base/ Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$ Source)
	at java.base/ Source)

I’m having the same error, on Catalina.

Were you able to fix it? After the error, I’m now unable to access the vault via iOS.

Looks to me like there are vault files missing or not available to cryptomator.
Please make sure all vault files are fully available. This includes the vault root folder (that is named like your vault), the masterkey file, the “d” forlder and all subfolders/files.
See also here:

Hi @Michael - All of my files are present. I didn’t change anything in my vault itself, just tried to open it and am seeing this error.

It looks like you were able to solve this in your other thread? Can you give me more details on the steps you took? I’m also using GDrive to store my vault.