Vault lock failed with FUSE/WinFSP

Today I upgraded Cryptomator to V1.6.1 and also tried it with FUSE / WinFSP.

I noticed that when using FUSE, I cannot lock my vault. I always get the message, that there are open files or pending operations on the drive (even if I only opened the vault without changing anything).

In the debug-log I found the problem: there is an exe-file in the root directory of the vault:
16:17:35.741 [fuseMount-5-main] WARN o.c.frontend.fuse.OpenFileFactory - Closing unclosed file OpenFile{path=/xyz.exe,}

When using Dokany, I never had this problem.

Anyone else has this problem? Is this a bug of the WinFSP implementation?


Has someone tried to reproduce this? Or is it just me who has this problem?

For me, this is very anyoning because the message “there are open files or pending operations” always gives me a bad feeling, when I have to force to lock the vault. Of course I can use Dokany, but it looks like WinFSP is the better and in the future prefered driver…?

I do not have such Problems using WinFsp or dokany.

Michael, have you tried to copy an exe-file to the vault, execute and close it an then try to lock the vault?

I tried this on an other PC with a fresh installation of Cryptomator and a newly created vault and encountered the same problem?

Indeed, I havent tried with exe files. And for fuse I can reproduce that, but have no clue what is causing this.
The cryptomator log files says the exe file is still accessed by a process, but I cannot find a handle that actually does.
(tried with the tool “process explorer” and also with Windows ressource monitor.)
Actually I am clueless.

I also checked this, by placing a single exe file into a vault. Everytime the vault is opend the exe file is executed, the lock afterwards fails und i have to force lock. I’ll have to look deeper into this.