Vault files cannot be read

Cryptomator 1.12.3 (dmg-5219)
Volume Type: FUSE-T
Running on macOS 14.5

Scenario: My vault lies in my Outlook, have been using it for more than 6 months now. Today I did some file IO inside the unencrypted vault (a lot of writes) and now my (unencrypted) vault shows up empty.

Relevant logs (attached): cryptomator0.log and healthreport.log
cryptomator0.log (311.0 KB)
healthReport_Cryptomator_20240630-091828.log (72.4 KB)

Can anyone please help with the recovery? I have already tried freeing up Onedrive files cached locally just to see if it syncs vault folders correctly again. Also tried adding the vault again.

Your log contains a lot AccessDeniedExceptions. Please make sure, that Cryptomator/other applications have regular file access to your OneDrive storage.

1 Like

What should the UNIX permissions look like? Typically for all files under MY_DATA ?

For some weird reason the way I could fix it was going through apples folder permissions menu and then setting it for myself to be an accessor even though it shows that I can access it.

1 Like