Vault Created on Android giving error while opening on windows 10 PC

I purchased the android app today and created a vault in my Gdrive. I synced the Gdrive with my laptop (windows 10 Pro) folder.

I downloaded the latest cryptomator application (1.5.16) from web today and installed on my laptop. In the vaults list, I added the vault that I created in my Gdrive folder.

However when I try to unlock the vault, I am getting an error with the windows app. Following is the error.

org.cryptomator.common.vaults.Volume$VolumeException: Unable to mount Filesystem
	at org.cryptomator.common.vaults.DokanyVolume.mount(DokanyVolume.java:48)
	at org.cryptomator.common.vaults.Vault.unlock(Vault.java:151)
	at org.cryptomator.ui.unlock.UnlockWorkflow.attemptUnlock(UnlockWorkflow.java:100)
	at org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:81)
	at org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:44)
	at javafx.concurrent.Task$TaskCallable.call(Task.java:1425)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.base/java.lang.Thread.run(Unknown Source)
Caused by: org.cryptomator.frontend.dokany.DokanyMountFailedException: Error while mounting.
	at org.cryptomator.frontend.dokany.MountFactory.mount(MountFactory.java:130)
	at org.cryptomator.frontend.dokany.MountFactory.mount(MountFactory.java:116)
	at org.cryptomator.common.vaults.DokanyVolume.mount(DokanyVolume.java:43)
	... 11 more
Caused by: com.dokany.java.DokanyException: Mount timed out
	at com.dokany.java.DokanyMount.mount(DokanyMount.java:121)
	at org.cryptomator.frontend.dokany.MountFactory.mount(MountFactory.java:126)
	... 13 more

Please let me know what to do.

-Alok

Please read this and increase timeout threshold of Dokany

Hi Michael,

I forgot to mention in my earlier post. I tried the fix mentioned in the above post. And increased the timeout to 30 seconds, then to 40 seconds and then even to 60 seconds. Yet, the same error.

I had a previous version already installed on my laptop, but with that version, the vault did not open either as it raised error that the vault was created with a newer version. That’s why I installed the latest version.

Please tell me how can I open the vault or have I made a mistake by paying up for the android app?

Also another question, Assuming that timeout value should be more than 60 seconds (which I have not tried yet), why is it taking so long to open the vault which takes just a few seconds on android app?

-Alok

I don’t think that increasing the threshold more will yield any substantial results.

Dokany freshly released a new version of their library which might resolve this feature, you can download it here (pick the file “Dokan_x64.msi”): Release 1.5.0.2000 · dokan-dev/dokany · GitHub
We welcome feedback if this resolves your situation.

There is also a workaround: Change the technology to integrate your vault into the system. You can do it in the general preferences of Cryptomator, tab “virtual volume”. Use either WebDAV (legacy, has known issues) or FUSE.

We suggest FUSE. Before you can select it in Cryptomator, you need to install WinFSP (an alternative to Dokany).

Hi,

Thanks for your response. Following is my feedback on the two options that you suggested.

  1. Dokany version 1.5.2000 - The current installed version is already 1.5.2000 and the installer (msi file) did not allow installing it again. So its not working!

  2. Second option of changing the virtual volume to WebDAV did work and the vault did unlock in less than a couple of seconds. So this option is working (for me).

PS: The virtual drive->volume type did not have FUSE option even after installing WinFsp. Only showed WebDAV / Dokany options

Thanks Again,

-Alok

© 2021 Skymatic GmbH • Privacy PolicyImpressum