Upgrade version 3 to 4 fails

I have just installed version 1.3.2 on my mac. However, when I try to open an existing safe, which was created earlier, I am notified that the container needs to be updated. When I enter my password and hit enter, I get the message “Versions-MAC konnte nicht authentifiziert werden” (I am using the German version), which means: “version MAC could not be authenticated”.

I have no idea what this message means and how I can resolve the issue.

Pleaase help!

If you see this error, you probably created your vault with an older version of Cryptomator for iOS. The version MAC was incorrectly calculated on iOS due to an implementation error.

There is a workaround to upgrade your vault nonetheless:

  1. Download version 1.1.4 again (https://github.com/cryptomator/cryptomator/releases/tag/1.1.4) and open it.
  2. If you haven’t used 1.1.4 before, you might have to upgrade your vault, before proceeding with step 3. If you even have to upgrade the vault can be seen on the button. It should read “Upgrade vault” instead of “Unlock vault”. If you don’t see any vault upgrade notice inside version 1.1.4, just skip this step.
  3. Keep your vault locked. Right-click on the vault in the list and select “Change password”.
  4. Change your password (you can keep your old password - an actual change is not needed). The version MAC will now be re-calculated after confirming your new password.
  5. Open up version 1.3.2 again and proceed with the vault upgrade.


thank you for your help. Worked well as described.

Best regards


1 Like

Yes this worked for me also!

Thank you.