Unlock fails after transferring to new iPad

I have transferred all data from one iPad to another (via Settings > General > Transfer or Reset iPad). On the new iPad, in the Files app, Cryptomator refuses to unlock the vault with the error message “Unable to perform unauthorized operation.”

In Cryptomator settings > Cloud Services > Dropbox > Authentications, I checked if I am signed in. I am. If I am signed in, why is there an authentication error?

I removed the vault from the Vault List and added it back. I allowed Cryptomator to access Dropbox. I am still not able to unlock the vault in Files.

Next, I signed out of Dropbox from within Cryptomator, then re-added the vault. I am still not able to unlock the vault in Files. This time, in Cryptomator I get the error message “The operation couldn’t be completed. (CryptomatorCommonCore.File-ProviderXPCConnectorError 4.)”.

I can unlock from the original iPad and also from another iPhone. So, there seems to be a bug specifically related to transferring entire systems between devices.

Any comments?

I should add that I can access the vault from Cryptomator 1.6.3 (770) on the new iPad.

This issue seems to have resolved itself. I guess it might have to do with a Dropbox limitation. You can only have 3 connected devices.

It would be nice if Cryptomator were able to convey such errors in more detail, so that there is less guesswork for the user.

1 Like