Unlock a safe created on W10 in Ubuntu 20.04.02 LTS

Hi all, I can’t unlock a safe created on W10 in Ubuntu 20.04.02 LTS brings me this error:

java.nio.file.FileSystemException: /mnt/62C84D6DC84D4091/Msi1TB/c: File system in sola lettura
	at java.base/sun.nio.fs.UnixException.translateToIOException(Unknown Source)
	at java.base/sun.nio.fs.UnixException.rethrowAsIOException(Unknown Source)
	at java.base/sun.nio.fs.UnixException.rethrowAsIOException(Unknown Source)
	at java.base/sun.nio.fs.UnixFileSystemProvider.createDirectory(Unknown Source)
	at java.base/java.nio.file.Files.createDirectory(Unknown Source)
	at java.base/java.nio.file.Files.createAndCheckIsDirectory(Unknown Source)
	at java.base/java.nio.file.Files.createDirectories(Unknown Source)
	at org.cryptomator.cryptofs.common.FileSystemCapabilityChecker.determineSupportedFileNameLength(FileSystemCapabilityChecker.java:118)
	at org.cryptomator.cryptofs.common.FileSystemCapabilityChecker.determineSupportedFileNameLength(FileSystemCapabilityChecker.java:95)
	at org.cryptomator.common.vaults.Vault.createCryptoFileSystem(Vault.java:115)
	at org.cryptomator.common.vaults.Vault.unlock(Vault.java:147)
	at org.cryptomator.ui.unlock.UnlockWorkflow.attemptUnlock(UnlockWorkflow.java:100)
	at org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:81)
	at org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:44)
	at javafx.concurrent.Task$TaskCallable.call(Task.java:1425)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.base/java.lang.Thread.run(Unknown Source)

Many thanks in advance

Welcome to the Cryptomator Community :slightly_smiling_face:

The vault storage location is read only. You need to activate the read only option in the vault specfic options, otherwise Cryptomator tries to determine certain vault parameters but creating some test files.

1 Like

Ok putting only reading opens it correctly but in this way I can not (rightly) modify the files inside …

how should I do to be able to open in both reading and writing without that error above?

Thanks so much.

This is something you have to figure out. Is the vault storage location accessible with write access by you? If not, you need to fix that first.

1 Like

yes the location is with write permissions

I had the same problem as you when i tried to open my vault on my dual boot computer.
I disabled fast startup in windows 10 and now it works (I don’t know why but i would like to ).

In case you don’t know how to disable fast startup look at the link