"unexpected error occured" when opening vaults after update to v1.15.15 (Mount timed out)


  • Windows 10 Pro 19042.928
  • Cryptomator v1.15.16
  • four vaults, two local file system, one in Box.net, one in Google Drive

All my vaults fail to open after entering the correct passcode (see error below). All worked properly before the update. I was using the previous version, ran the update, re-started computer, and ran CM and then errors occur.

What I’ve done:

  • I’ve uninstalled CM, rebooted, and re-installed CM.
  • After reading many other posts, I’ve tried uninstallng, re-installing DOKANY multiple times.
  • Tried WEBDAV and it works, but I prefer to use DOKANY due to the size restrictions.

Now, still not being able to access my vaults, I need help…

thank you.

org.cryptomator.common.vaults.Volume$VolumeException: Unable to mount Filesystem
	at org.cryptomator.common.vaults.DokanyVolume.mount(DokanyVolume.java:48)
	at org.cryptomator.common.vaults.Vault.unlock(Vault.java:151)
	at org.cryptomator.ui.unlock.UnlockWorkflow.attemptUnlock(UnlockWorkflow.java:100)
	at org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:81)
	at org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:44)
	at javafx.concurrent.Task$TaskCallable.call(Task.java:1425)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.base/java.lang.Thread.run(Unknown Source)
Caused by: org.cryptomator.frontend.dokany.DokanyMountFailedException: Error while mounting.
	at org.cryptomator.frontend.dokany.MountFactory.mount(MountFactory.java:130)
	at org.cryptomator.frontend.dokany.MountFactory.mount(MountFactory.java:116)
	at org.cryptomator.common.vaults.DokanyVolume.mount(DokanyVolume.java:43)
	... 11 more
Caused by: com.dokany.java.DokanyException: Mount timed out
	at com.dokany.java.DokanyMount.mount(DokanyMount.java:120)
	at org.cryptomator.frontend.dokany.MountFactory.mount(MountFactory.java:126)
	... 13 more

I think this has to do with the update to javafx 16.
I tried for 5 minutes to get info on

  • which version I have on W10
  • where can I get the download link to javafx 16 to update

No success => W10 system restore!
The last version of Cryptomator works.

I’ll wait until someone shows how to update to 1.5.15.

See Changelog:

Misc :wink:
Updating to JavaFX 16

thanks @cc6145 I reverted to the previous version and it works! Thanks

Thanks for reporting this problem! We have found the issue (too low time threshold to wait until the mount is completed) and will publish a fix asap.

Ticket on our issue tracker:

1 Like

This error is still happening for me in 1.15.16.

If I go thru a few crashes, I can eventually get it to open.

Did you try to increase the timeout limit like it is described in the GitHub issue?

@Michael I donwgraded before seeing the tip about increasing the timeout. It works fine on the lower version so I’ll wait until the update.


Follow this link https://github.com/cryptomator/cryptomator/issues/1627#issuecomment-826059258 courtesy of @infeo for solution.

1 Like

v16 did NOT fix it for me. Same problem, no change. Went back to v14 - https://github.com/cryptomator/cryptomator/releases/download/1.5.14/Cryptomator-1.5.14-x64.exe