Unable unlock the vault

Hi guys, this morning Cryptomator 1.6.8 version update came, after the installation unable to open the Vault using the same password that was working just before the update. The following message is appearing:

Error Code TMN6:3HIN:3SJV
org.cryptomator.common.vaults.Volume$VolumeException: Unable to mount Filesystem
	at org.cryptomator.desktop@1.6.8/org.cryptomator.common.vaults.DokanyVolume.mount(DokanyVolume.java:48)
	at org.cryptomator.desktop@1.6.8/org.cryptomator.common.vaults.Vault.unlock(Vault.java:153)
	at org.cryptomator.desktop@1.6.8/org.cryptomator.ui.keyloading.KeyLoadingStrategy.use(KeyLoadingStrategy.java:79)
	at org.cryptomator.desktop@1.6.8/org.cryptomator.ui.unlock.UnlockWorkflow.attemptUnlock(UnlockWorkflow.java:72)
	at org.cryptomator.desktop@1.6.8/org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:62)
	at org.cryptomator.desktop@1.6.8/org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:35)
	at javafx.graphics@18/javafx.concurrent.Task$TaskCallable.call(Task.java:1426)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.base/java.lang.Thread.run(Unknown Source)
Caused by: org.cryptomator.frontend.dokany.DokanyMountFailedException: Error while mounting.
	at org.cryptomator.frontend.dokany@1.3.3/org.cryptomator.frontend.dokany.MountFactory.mount(MountFactory.java:130)
	at org.cryptomator.frontend.dokany@1.3.3/org.cryptomator.frontend.dokany.MountFactory.mount(MountFactory.java:116)
	at org.cryptomator.desktop@1.6.8/org.cryptomator.common.vaults.DokanyVolume.mount(DokanyVolume.java:43)
	... 12 more
Caused by: com.dokany.java.DokanyException: Dokany not properly installed (Reported versions: 151/0
	at org.cryptomator.frontend.dokany@1.3.3/com.dokany.java.DokanyMount.checkReportedVersions(DokanyMount.java:140)
	at org.cryptomator.frontend.dokany@1.3.3/com.dokany.java.DokanyMount.mount(DokanyMount.java:88)
	at org.cryptomator.frontend.dokany@1.3.3/org.cryptomator.frontend.dokany.MountFactory.mount(MountFactory.java:126)
	... 14 more
........

I try to uninstall the App, and installed the previous version, unfortunately same error appearing, unable to open the vault

I have very impermanent documents in the vault, need help please
Thanks

Hey and welcome to the Cryptomator Community :slightly_smiling_face:,

See e.g. Vaults cannot be opened anymore - #3 by Michael and Error TMN6:3HIN:3SJV 路 Discussion #2004 路 cryptomator/cryptomator 路 GitHub regarding this problem.

OMG how do i access my files then ?

Did you read the linked posts?

Apologies, actually I鈥檓 a non-technical person, so difficult for me to understand certain things. I think the solution given in the link seems to update Donkey or something

Can you correct me if i鈥檓 wrong please?

You can fix this in two different ways:

  1. Uninstall you current Dokany version and reinstall the latest 1.x version (not the 2.x version). Just follow this post how you do both of it: Error TMN6:3HIN:3SJV 路 Discussion #2004 路 cryptomator/cryptomator 路 GitHub
  2. Replace Dokany with FUSE by following WinFSP: How to use it

鈥hen you will have access to your vault again :slight_smile:

Thank you so much, when i follow the link it says 1.5.1.1000 version of the Donkey i鈥檝e downloaded the .exe file and i will uninstall the older version and i will install the newer version

Here i need to trouble you with one more question also it seems

This Donkey is it used only for Cryptomator or used for any other applications too like GnuPGP etc as well?

The reason for asking, if i uninstall and install the new version will it affect my GnuPGP as well ?

My existing Dokany says 1.4.1鈥 version

do i need to follow uninstall and install again as per your instructions ?

Thank you so much SailReal鈥 FUSE worked well and i鈥檓 able to open my Vault and it is working perfectly fine Thanks

1 Like