Unable to use linux desktop in chromebook's linux

i have installed ctmt inside chromebook’s linux,
by appimage AND flaktap?.

both result in the GUI missing the menu etc,
and for the window that select folder for container,
its blank empty.

i have also tried to use sirikali as GUI,
but it use a specially cooked CLI command which i dont think i will use:

i am very disappointed, it likely means they didn’t have a chromebook and didn’t check that before release.

chromebook is very very popular and un-supporting is disappointing.

every OS and application are the most updated versions.

author would know by checking the time.

my current situation:

i got a almost unlimited google drive,
i must put an encryption layer on it.

i use windows, android, chromebook, may be crostini.
cryptomator SHOULD run on all of them, thus solve my problem.

boxcryptor, which ctmt forum kindly allowed to talk about, collapsed as you all know. but before the collapse, it ran on all these too.

gocryptfs/cppcryptfs, do work well on windows, linux/crostini. however it is not fit for android.

mostly, that’s because gocryptfs is not designed for mobile, and no one wants to work on an arm race /w google’s document provider.

so i really hope ctmt could work inside crostini, which previously does.

I use cryptomator everyday on my Chromebook.
I’m running the flatpak version.
Everything seems to work OK.

1 Like

i am not sure are yours arm or x86,
what CrOS version, mine is arm + lastest CrOS , indeep lenovo duet 2020.

it didn’t work as shown above.

i tried all the methods.

pls just assume i am a layman, i am uneducated, i sell vegetables in market, i am an middle age female.

i failed to run ctmt on my CB.

@ccchan ,

Not sure exactly what to say to help. Perhaps my notes below will help.

My Chrome OS is: Version 121.0.6167.188 (Official Build) (64-bit)
My processor is Intel i5.
My Linux was just upgraded to Debian 12, but 11 worked fine too.

It runs and looks just like Crptomator on windows.

I don’t know what sirikali is, and it’s not loaded.

I’m a fairly heavy Chromebook user. It is my primary computer.
I have 16 GB RAM, and a self installed 1 TB SSD.

I run many Linux apps, some from the repo, appimage, and Flatpak.

I use:
Libre Office
Betterbird (Fork of Thunderbird email) With ChOS fixes.
Rclone (For mounting cloud drives like Google, Onedrive, and others.

Cryptomator talks to Google Drive via Rclone, which also runs in the Linux container.

How specifically are you navigating to your Google Drive from inside cryptomator? Are you going through the ChromeOS/Linux sharing which uses the /mnt directory?
Long form is: /mnt/chromeos/GoogleDrive/MyDrive

I mount Googe Drive via Linux Rclone, so my vault is at:

My other vault is on my PCloud Drive, and I’m getting there using the linux client software from pcloud.

Hope this helps.

i have lost my patience on ctmt…