Unable to access vault after reformatting computer?

Hello - I just recently installed Cryptomator for the first time on my linux desktop, I had encrypted my cloud drive and mounted it worked just fine. I then formatted my computer, reinstalled Linux and then attempted to mount my cloud drive with Cryptomator and have had nothing but problems. First it would not accept my password which I was certain was correct. Then after using my recovery phrase I reset the password but when I logged in and tried to access my existing vault I am stuck with the wheel which keeps turning like it is working at it but it never mounts. I have given it 24 hours and tried to restart and login in again however when I try to access my existing vault it won’t mount and the wheel forever turns.

Any suggestions on what may have gone wrong?

I would attempt to mount via the Flatpak provided client; if it doesn’t work then one would be reasonably sure it isn’t a software library/dependency issue.

Thank you, I did install Cryptomator from the flatpak repository since it was not found in my package library.