Tresor wird unter allen Geräten als "leer" dargestellt - Definitiv sind aber viele GB im Ordner unter GDrive gespeichert

Einen schönen guten Tag zusammen,

ich finde den Cryptomator prima und habe ihn nun das erste Mal und nach langem Testen produktiv im Einsatz. Dafür habe ich alle meine Dateien aus Google Drive in einen Tresor verschoben und diesen hochgeladen (ich nutze MacOS und habe dafür die Google App zum Backup und Synchronisation von GDrive genutzt.

Nun ist die Synchronisation abgeschlossen und unter welchem Gerät ich schaue, der Tresor unter GDrive wird als “leer” gekennzeichnet. In der Cloud selbst sehe ich alle Dateien (verschlüsselt) und die GB Angabe passt. Auch die Key-Datei ist vorhanden!

Vom Vorgehen her:

Ich habe einen verschlüsselten Ordner in der Cloud
Ich habe den Cryptomator geöffnet und finde auch den Tresor (Seltsamerweise öffnet er immer ein “Laufwerk”, der Tresor selber liegt aber im Ordner GDrive und den synchronisiere ich auch mit Google)
Mir wird immer das Laufwerk angezeigt, das aber komplett leer zu sein scheint
Auch alle anderen Endgeräte zeigen mir einen leeren Tresor an, ich habe die App überall aktualisiert und die Tresore mehrfach entfernt und wieder eingefügt.

Könnt ihr mir helfen? Ich habe alle Dateien nur noch im Tresor :frowning:

Vielen Dank!

Hier auf Englisch:

Have a good day together, I think the Cryptomator is great and have now been using it productively for the first time and after a long test. To do this, I moved all my files from Google Drive to a vault and uploaded it (I use MacOS and used the Google app to backup and synchronize GDrive. Now the synchronization is complete and under which device I look, the vault under GDrive is marked as “empty”. In the cloud itself I see all files (encrypted) and the GB specification fits. Also the key file is available!
From the procedure: I have an encrypted folder in the cloud I have opened the Cryptomator and also find the vault (strangely, it always opens a “drive”, but the vault itself is in the GDrive folder and I also synchronize it with Google) I am always shown the drive, which seems to be completely empty. All other devices also show me an empty safe, I updated the app everywhere and removed and reinserted the safes several times.

Can you help me? be all files only in the vault: frowning:

Thank you very much!

Dass du das seltsam findest, suggeriert, dass du mit dem Laufwerk bisher nichts getan hast, liege ich da richtig?

Nur, um ein Missverständnis vorzubeugen: Dateien einfach in den Tresor-Speicherort auf Google Drive zu verschieben, sorgt nicht für eine Verschlüsselung.

Diese müssen schon in besagtes Laufwerk reingepackt werden. Nur dann werden sie verschlüsselt und nur dann kannst du auch aus den Mobil-Apps darauf zugreifen.

Hi,

Nein ganz so schlimm ist mein Wissen nicht. Das mit dem Laufwerk ist aber ein neues Verhalten, vorher war es ein einfacher Ordner. Die Verschlüsselung ist mir auch mehrfach und auch in diesem Fall komplett gelungen. Es gibt in der Cloud meinen Tresor der enthält den Schlüssel und zwei Ordner (die der Cryptomator erstellt hat) welche wiederum eine Vielzahl an Unterordnern und verschlüsselten Dateien enthalten.

Ich habe auf meinem Mac nun einmal den synchronisierten Gdrive Ordner in dem sich der Tresor befindet und wenn ich den Cryptomator öffne, dann öffnet sich das Fenster des Finders, der wiederum das Laufwerk anzeigt (gleicher Name wie der Ordner unter Gdrive). Das Laufwerk ist aber leider leer.

Definitiv gibt es den Tresor, der lässt sich auch über den Schlüssel öffnen - er wird nur als leer angezeigt. Doch das „Leer“ umfasst 10 GB verschlüsselte Dateien.

Vielleicht noch einmal ganz konkret: ich habe in der cloud einen Ordner voller verschlüsselter Dateien inkl. dem Sicherheitsschlüssel. Wenn ich den Tresor öffne (auch neu einrichte), dann öffnet er ihn auch (ich kann neue Dateien hochladen), aber er sieht alle Dateien nicht, die dort verschlüsselt sind. Und das Gerätunabhängig.

Guten Abend zusammen,

ich versuche es noch einmal mit einem neuen Topic, da ich leider echt nicht weiter weiß.

Anfang Mai habe ich mein gesamtes Google Drive Laufwerk in einen Ordner gepackt und diesen dann über den Cryptomator verschlüsselt und das ganze Paket wieder mit der Cloud synchronisiert. Die Größe der Datei entspricht auch den hochgeladenen Daten.

Nun habe ich den Ordner komplett aus Google heruntergeladen inkl. der Masterdatei und den Backups. Wenn ich den Tresor dann über die Masterdatei öffne wird mir der Ordner als “leer” angezeigt. Wie bekomme ich nun alle Dateien wieder entsperrt? Helfen mir die Backups der Masterdatei? Ich verstehe nicht, wie der Ordner komplett verschlüsselt sein kann, der Masterkey den Tresor auch öffnet aber die Dateien alle nicht wieder entschlüsselt werden.

Was kann ich tun?

Ist vielleicht durch die Synchronisation per Google Drive etwas schief gegangen?

Ein Cryptomator-Tresor folgt einem bestimmtem Ordner-Schema, das in etwa so aussieht:

Auch wenn mir durchaus bewusst ist, dass die Ordner-Struktur wahrscheinlich sehr groß ist und man nicht alles prüfen kann, aber lässt sich stichprobenartig diese Struktur wiedererkennen? Insbesondere dass im Ordner d ausschließlich Ordner befinden mit 2 Zeichen. Und in diesen Ordnern mit 2 Zeichen liegen ausschließlich Ordner mit 30 Zeichen.

Lässt sich im leeren Tresor überhaupt eine Datei anlegen?

Wenn der leere Tresor nur offen ist, könntest du probeweise von außen eine beliebige, kleine Datei hineinziehen. Klappt dies überhaupt? Und wenn du den Tresor sperrst und erneut entsperrst, ist diese neue Datei dann zu sehen?

Hallo zusammen,
das gleiche Problem habe ich auch mit OneDrive. Was bei mir geht, wenn ich den Tresor auf eine externe Festplatte kopiere, habe ich wieder Zugriff bzw. sehe alle Dateien in den Folder. Auf dem gleichen Rechner habe ich auch eine Sync. mit BOX, da habe ich keine Probleme mit leeren Ordnern. Auf einem anderen Laptop funktioniert die Kombination Cryptomator mit 1.5.4. und Onedrive und habe keine leeren Ordner. Bis dato habe ich keine Idee, woran es liegen kann. Der einzige Unterschied ist, dass der eine Laptop (mit der leeren Ordnerproblematik) über eine Unternehmenspolice gemanagent wird…

Hallo,

ich hatte bis gerade eben dasselbe Problem mit meinem Tresor in iCloud. Nach dem Update auf die neueste Version von Cryptomator (V1.5.4) und der zwangsläufigen Aktualisierung des Tresors wurde mein Tresor über das iPhone als leer dargestellt. Ein kurzer Check in iCloud hat mich beruhigt, da alle Dateien weiterhin vorhanden waren.

Wie also den Cryptomator Client auf dem iPhone davon überzeugen, dass er die Dateien wieder einliest…?

Was genau den Ausschlag gegeben hat, kann ich nicht sagen, jedoch nach den folgenden Aktionen kann ich auf dem iPhone wieder auf die Dateien in meinem Tresor zugreifen:

  • Tresor im iPhone umbenennen
  • Tresor löschen
  • Tresor wieder einbinden (-> vorhandenen Tresor hinzufügen)
  • Neue Testdatei in der Quelle (= Windows PC) in den Tresor hinzufügen
  • Sync Quelle mit iCloud

Siehe da, auf einmal werden wieder alle Dateien auf dem iPhone angezeigt.

Hoffe das hilft.
Grüße

© 2020 Skymatic GmbH • Privacy PolicyImpressum